
Make your work more efficient

CHCNAV CoProcess SW
User Manual
Version 2.6

Mobile Mapping | DECEMBER 2023



Table of Content

1. Software Introduction ............................................................................................... 1

1.1.1. Browse Platform.......................................................................................... 1

1.1.2. Terrains Module ...........................................................................................2

1.2. Hardware Requirement ........................................................................................ 3

1.3. Software Install .....................................................................................................3

1.4. Software Uninstall ................................................................................................ 4

1.5. Software Registration........................................................................................... 4

1.5.1. Apply for Trial ...............................................................................................4

1.5.2. Dongle and Registration Code ..................................................................... 5

1.5.3. Redemption Code ........................................................................................ 6

2. Software UserGuide .................................................................................................. 7

2.1. Terrains User Guide ...................................................................................................7

2.1.1. DEM Producing ............................................................................................ 7

2.1.2. Contour&Elevation points Generation ...................................................... 24

2.1.3. Buildings outline Extraction.......................................................................30

2.2. Terra Parameter description ................................................................................... 47

2.2.1. Isolated point (noise) filtering ................................................................... 47

2.2.2. Low point filtering ......................................................................................49

2.2.3. Ground point filtering（地面点） ............................................................ 51

2.2.4. Key Points Parameter Description ............................................................. 66

2.2.5. Contours Generation ................................................................................. 69

2.2.6. Contours Smooth .......................................................................................71

2.2.7. Elevation points Generation ...................................................................... 73

2.2.8. Contours Simplify .......................................................................................75

2.2.9. Generate elevation points ......................................................................... 77

2.2.10. Building Filtering ........................................................................................ 80

2.2.11. Vegetation Filtering ....................................................................................87



2.2.12. Extracting building Outline ........................................................................ 89

2.2.13. Buildings Editing .........................................................................................96

2.3. Roads User Guide ............................................................................................... 98

2.3.1. Introduction............................................................................................... 98

2.3.2. Step-by-step.............................................................................................100

2.3.3. Import Point Cloud .................................................................................. 100

2.3.4. Obtain pile by pile ....................................................................................101

2.3.5. Pile Add(Not Necessary) .......................................................................... 106

2.3.6. Generate Section ..................................................................................... 107

2.3.7. Vertical section editing ............................................................................ 109

2.3.8. Edit Section .............................................................................................. 110

2.3.9. Vector Editing ...........................................................................................111

2.3.10. Exporting Survey Results ......................................................................... 111

2.3.11. Generate Section View............................................................................ 111

2.4. Volume User Guide ...............................................................................................113

2.4.1. Introduction............................................................................................. 113

2.4.2. Sample data ............................................................................................. 113

2.4.3. Work Flow................................................................................................114

2.4.4. Preprocessing ...........................................................................................115

2.4.5. Projected Volume Calculation ................................................................. 118

2.4.6. Volume Comparison ................................................................................ 122

2.4.7. Change Analysis ....................................................................................... 124

2.4.8. Bench Lines .............................................................................................. 128

3. Software UserManual ............................................................................................130

3.1. File&Project ...................................................................................................... 130

3.1.1. Open Resources ....................................................................................... 130

3.1.2. Save Resources ........................................................................................ 130

3.1.3. Open Point Cloud .....................................................................................130



3.1.4. Open Model .............................................................................................135

3.1.5. Export Point Cloud ................................................................................... 136

3.1.6. Convert Terrain Model .............................................................................137

3.1.7. Convert Codata ........................................................................................ 138

3.1.8. System Settings ........................................................................................139

3.1.9. Theme...................................................................................................... 143

3.2. Home................................................................................................................ 144

3.2.1. View Direction ......................................................................................... 144

3.2.2. View Scale ................................................................................................ 144

3.2.3. View Control ............................................................................................ 144

3.2.4. Scene Roam............................................................................................. 147

3.2.5. ViewManagement ...................................................................................149

3.2.6. Colorization ..............................................................................................150

3.2.7. Tools .........................................................................................................156

3.2.8. Clipping .................................................................................................... 158

3.2.9. Measurement .......................................................................................... 163

3.2.10. Slice ..........................................................................................................176

3.2.11. Windows.................................................................................................. 178

3.3. Terrains ..................................................................................................................182

3.3.1. Import Las ................................................................................................ 182

3.3.2. Work Flow................................................................................................183

3.3.3. Block Management ..................................................................................202

3.3.4. Category Editing .......................................................................................203

3.3.5. Building Extraction ...................................................................................213

3.3.6. Contour Edit .............................................................................................221

3.3.7. Text Annoation .........................................................................................226

3.3.8. DEM......................................................................................................... 229

3.4. Roads ................................................................................................................ 238



3.4.1. Project Manager ...................................................................................... 238

3.4.2. Road Parse ............................................................................................... 239

3.4.3. Road Survey ............................................................................................. 248

3.4.4. Other Tools ...............................................................................................258

3.5. Volume..................................................................................................................264

3.5.1. Project Manager ...................................................................................... 264

3.5.2. Point Cloud Processing ............................................................................ 265

3.5.3. Triangulation ............................................................................................268

3.5.4. Single Volume Calculation ....................................................................... 271

3.5.5. Multi Volume Calculation ........................................................................ 274

3.5.6. Vector Achievements ...............................................................................278

3.5.7. Vector Line Processing .............................................................................279

3.5.8. Reference Plane ....................................................................................... 284

3.5.9. TIN Editing ................................................................................................285

3.5.10. Crop ..........................................................................................................288

3.6. Help .................................................................................................................. 291

3.6.1. Help ..........................................................................................................291

3.6.2. Version ..................................................................................................... 291

3.6.3. Update ..................................................................................................... 291

3.6.4. Language ..................................................................................................291



CHCNAV COPROCESS2.6 USER MANUAL P a g e | 1

1. Software Introduction
CoProcess software is based on the independent research and development of the
underlying rendering and vector interaction engine, adopts the "1+N" new development and
application model of "one platform, multiple industry modules", and provides SDK to
support customers in secondary development of application modules. The system provides a
variety of platform functions such as massive multi-source data management, 3D rendering,
vector drawing and symbolization, measurement and quality inspection, and for the needs of
different industries, targeted development of supporting industry application modules:

 Filter module for 3D lidar fields;

 Terrains module for traditional surveying and mapping fields;

1.1.1. Browse Platform

1.1.1.1. Massive point cloud rendering
The software uses a custom format (*.codata) to quickly visualize massive point cloud data,
and can quickly build *.las, *.txt, *.csv, *.pts and *.xyz into codata through LOD technology.
Covers conventional renderings such as height, intensity, RGB, classification, single, time,
returns, return number, etc. It provides multi-hue rainbow, blend and mix rendering, and EDL
effects improve rendering detail contrast

1.1.1.2. Scene Roam
Realize the scene roaming of point clouds, vectors and images, perform viewpoint roaming
according to the viewing angle position, and perform trajectory roaming by setting the
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browsing path.
1.1.1.3. Clipping

It provides rectangle and polygon selection of point cloud, and provides the functions of
inner clipping, outer clipping, clearing and saving of point cloud.

1.1.1.4. Measurement
It provides single point, multi-point, distance, area, density and angle measurement. In
addition to basic measurement, the software also provides elevation inspection, density
quality inspection and profile analysis functions.

 Provide point cloud density quality inspection, and can generate point cloud density

reports.

 You can draw multiple sections, move the position of the section, adjust the width of

the section, and open multiple sections at the same time for comparative analysis.

1.1.2. Terrains Module

1.1.2.1. Automatic Processing
Automatic processing to output DEM results that meet the accuracy requirements.

1.1.2.2. Intelligent Block
According to the point cloud density and range, quickly and intelligently block and generate a
block project.

1.1.2.3. Automatic Filtering
Several sets of common parameters are provided for different terrains, which can quickly and
accurately extract ground points under complex terrains. In addition, the software also
provides filtering processing of outliers, low points, and key points.

1.1.2.4. Manual Editing
After filtering, the point cloud can quickly construct a TIN, which is convenient for viewing
the terrain. It provides quick classification functions such as manual editing of point clouds,
simultaneous editing of point clouds and TINs, and section editing, as well as functions such
as category saving, modification, and export, which improve the user experience and ensure
that the classification result point cloud that meets the job requirements can be output.

1.1.2.5. DEM Linkage
The 2D and 3D view synchronization update method can quickly realize the update of DEM .
The 2D view loads DEM with large data area, which is convenient for operators to view the
overall DEM and quickly locate the area range that needs to be modified in the edge part.
Select the specified area in the 2D view to display it in the 3D view synchronously. The 3D
view edits the DEM, and at the same time, the editing results are updated and saved to the
overall DEM data in real time.

1.1.2.6. DEM Editing
DEM editing provides a variety of editing methods such as elevation leveling, elevation
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smoothing, elevation deletion, patching invalid values, elevation patching, removing spikes,
and adaptive smoothing to quickly edit DEM results.

1.1.2.7. Contour lines and elevation points
Generate contour lines based on point cloud in the block and DEM and elevation points,
provide three ways to smooth the generated contours, and also provide contour
simplification function.
Elevation points can be extracted directly based on ground points according to regular grid.

1.2.Hardware Requirement

Operating system
Microsoft Windows 7 (64bit)
Microsoft Windows 10 (64bit)

CPU
Minimum: Intel Core i5,2+ GHz
Recommend: Intel Core i7, 3.5+ GHz

Memory
Minimum: 8GB
Recommend: 16GB+

GPU
Minimum: 4GB
Recommend: 8GB

Display resolution 1920*1080 above
graphics card NVIDIA GeForce 1050 Ti +

1.3. Software Install

Note: Turn off 3rd party antivirus software, in case the install process being interrupted. And
the install path needs complete English letters.

 Open software package then click “I agree” and continue install:
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 Waiting software install completely:

 When software installed successfully, click finish to close current interface:

1.4. Software Uninstall
First way, click “Start” to open windows start menu. Find CoProcess2 folder then click
“Uninstall CoProcess2” and click yes to start uninstall.

Second way, go to “Settings – Apps”, and find CoProcess2.2 then right click to uninstall.

1.5. Software Registration
The software registration supports four methods: Apply for trial, dongle, registration

code and redemption code.

1.5.1. Apply for Trial

After the CoProcess software is installed, click the desktop icon of the CoProcess
software. After CoProcess is opened, click Help -> Licenses, then the license dialog box will
pop up.

On the “Apply for Trial” page, enter you mobile phone number, email address and
company name(optional), click the “Send verification” button and enter the verification code
you receive.
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Click the “Register” button. After the software restarts automatically, you can use the
charge module of the CoProcess software.

Apply for trial

Note:

The Internet connection is required when registering with a verification code.

1.5.2. Dongle and Registration Code

After the CoProcess software is installed, click the desktop icon of the CoProcess
software. After CoProcess is opened, click Help -> Licenses, then the license dialog box will
pop up and switch to the second page "Registration Code".

Send the hardware ID to us, and you can get the authorization code. Enter the
authorization code and click the “Register” button, then you can use the charge module of
the CoProcess software.
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Registration code

Note:

When the registration code is 3649838548, it means that the software does not detect
the NIC information.

When the user name is SUPERDOG, it means that there has been dongle in the
computer, please do not use the hardware ID to register! If the plug-in cannot be loaded at
this time, please contact the customer service of CHCNAV for help.

1.5.3. Redemption Code

After the CoProcess software is installed, click the desktop icon of the CoProcess
software. After CoProcess is opened, click Help -> Licenses, then the license dialog box will
pop up and switch to the third page "Redemption Code".

On this page, enter you mobile phone number and company name(optional) and the
redemption code you obtain.

Click the “Register” button. After the software restarts automatically, you can use the
charge module of the CoProcess software.
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Redemption code

Note:

Each redemption code can only be used once on one computer and cannot be
redeemed repeatedly.

The current computer cannot use other exchange codes during the validity period of
one redemption code.

The Internet connection is required when registering with the redemption code.

2. Software UserGuide

2.1. Terrains User Guide

2.1.1. DEM Producing

This document is intended to provide technical guidance for the production

process of traditional topographic DEM for users using CoProcess. The entire process

of DEM production is briefly presented using a single airborne lidar point cloud data

of approximately 10G.

This document does not involve detailed explanation of specific functions. If

necessary, please refer to CoProcess User Manual.

2.1.1.1. Sample data

The sample data used in this demonstration is the original LAS point cloud

collected by a single uav in a hilly area, with a total size of 11.5GB.
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2.1.1.2. Work Flow

The production process of traditional topographic DEM using CoProcess is

shown as follows:

Coprocess supports two DEM production methods: wizard and step-by-step.

Among them, wizard can greatly reduce the operation steps, guide new users to

operate well and quickly generate DEM results, which is suitable for the scene with
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low precision and urgent demand for results.

However, due to the lack of fine-grained editing of the point cloud category, the

resulting results may be less precise, in which case the step-by-step approach can be

used.

2.1.1.3. Wizard

The wizard can be divided into the following three steps: 1) Import point cloud

data; 2) Click “Wizard” button to set processing parameters; 3) Perform wizard

operations. The basic operations of these processes are described in detail below:

Step 1: Import the point cloud data to be processed and click “Wizard” button.
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Step 2: Set block parameters, filtering parameters and the result type, click

"Next" on the Wizard interface;

Filtering needs to select the corresponding processing parameters according to

the actual terrain, select "Hill" here.

Note: if you need to adjust the concrete block and filter parameters, check the

top right corner of the "advanced Settings", and do more Settings.
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Step 3: Click next and click "Start" button. The software will automatically

process the ground points and DEM under the block project path

After the processing is completed, click “Finish” to exit Wizard.

2.1.1.4. Step-by-step

The step-by-step can be divided into the following 6 steps: 1) Block; 2) Filtering;

3) Manual classification; 4) DEM generation; 5) DEM editor; 6) DEM quality

inspection. The basic operations of this process are described in detail below.

2.1.1.4.1. Block

The amount of airborne point cloud data in a single sortry is up to 11.5G, and it

is difficult to import all the data into the software for processing at one time.

Therefore, we can use the Block function to divide the original point cloud into

some small blocks for convenient data loading and editing.

Step 1: Add the point cloud file to be processed in the workspace, and click

“Block” button in the terrain module workflow to pop up the block window;
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Step 2: Set the grid size, block name and save path in the window.

Step 3: After confirming the grid parameter Settings, click “OK” button;

Step 4: After the block conversion is completed, a prompt will pop up whether

to load the block point cloud. Click "Yes" here for better subsequent operations.

2.1.1.4.2. Filtering

After the block operation is completed, the block point cloud is filtered to get

ground points.

Step 1: Click the filtering button.

Step 2: Select the block to be filtered. Here we choose the four blocks in the

lower left corner. If no selection is made, all blocks are selected by default.
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Step 3: Click “Next” to set the ground point filtering parameters. Considering

the actual terrain of the demonstration data, “Hill” mode is selected for ground point

filtering here. Users can adjust according to the actual terrain;

If there are special requirements for some filtering parameters in the actual

production, the functions of "isolated point filter" and "ground point filter" in

filtering processing can be used for parameter tuning, that is, adding small sections

of data for processing, so as to find suitable filtering parameters.

For isolated point filter, after selecting Auto Calculate, the software will

automatically calculate the filtering parameters.

Step 4: After filtering parameters are set, click Next and then click Start

generation to wait for filtering to complete.
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2.1.1.4.3. Manual Classification

After the completion of filtering, the results need to be checked and modified

due to the existence of ground point misclassification or missing classification. To

ensure smooth running, you are advised to load only one piece of point cloud data at

a time.

Step 1: Load block data.

Refer to the preview data, activate the "Block Management -> Select Block "

function, and select the grid to be loaded in the view to load and display.

Step 2: Adjust the color mode.

After grid points cloud data loaded, in order to facilitate to category editing of

point cloud, use the shortcut toolbar to switch the color mode to category color and

also set the categories to display.
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Click color Settings to unshow all categories except ground points (a) and then

show ground points only (b) to check for any errors in classification.

(a)

(b)

Step 3: Construct TIN to assist in viewing ground points.

After the ground points are loaded, it is difficult to detect misclassification or

missing classification just by looking at the point cloud. Therefore, we can display the

ground point information in the form of TIN through the TIN function.

Point cloud and TIN synchronously edit operation steps.

1.Load the partitioned point cloud file after classification and display the
partitioned points to build TIN.

2. Click “TIN” inCategory Editing and wait for TIN build to complete.
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When doing the profile editing, we can look at TIN to determine whether the

modification of the ground point has achieved the desired effect.

Step 4: Edit the point cloud category using Profile Editing.

When setting up the source and target classes, you can refer to the table below.

Condition Source Target

Misclassification Ground Undefined

Missing classification Undefined Ground

Steps for Profile Editing

1.Click “Profile Editing” button to open the section view and draw a section
parallel to the block boundary of the main view so that "cut" the point cloud data of
the main view into the section view;

2.Combined with the main view and section view, carefully check whether there

are wrong points or missing points point clouds, and use "upline " or"

downline " to draw lines and edit;

3.After each profile is checked, use move up or move down to change the

position of the profile shown in the profile view, and then edit the next profile;
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4.After editing a single grid dot cloud, you can right-click the currently edited
block data on the tree node and click "Delete Grid Data". The grid data will uninstall
and save the currently edited point cloud data.

5.Repeat the process until the ground points of all blocks have been corrected.

The following section editing steps will be introduced with specific examples.

Example 1: Profile editing operation:

As shown, for a body of water, use "downline " in profile editing to correct

the classification. Operation method:

1.Click on two points in the wrong section to draw a section;
2.Activate the downline tool, set the original category to ground and the target

category to undefined;
3.Draw a multi-segment line whose area below the line is full of misalignments;
4.Double click to end the drawing, you can complete the right and wrong

classification points for correction;
5.Repeat the process until all edits of the current block are complete.
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Example 2: Point cloud and TIN synchronous editing:

As shown in the figure, the TIN display in the main view also changed after we

corrected the misclassification of the roof as ground points in the section view by

using the "upline " tool.

Operation method:

1.Load block data with ground point information and construct TIN;
2.Open profile editing to modify misclassified ground points into undefined

points in an area;
3.Look at the TIN.
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2.1.1.4.4. DEM Generation

Through the previous editing operation, we can get the ground point cloud after

fine classification. Here, we will introduce the process of generating DEM by using

these point cloud data.

Step 1: Open the DEM generation tool. Click "Work Flow -> Export DEM" to

open the DEM generation tool. The pop-up page is similar to filtering, and you can

select blocks to be processed on this page.

Step 2: After selecting blocks, click Next to switch to the page of DEM

generation and set parameters of DEM generation;

Step 3: Set the output format and output type, and click Start button to start

DEM generation. Here we check the “Merge into single file” checkbox;

Note: Auto Calculate is checked here. If you want to customize DEM parameters,

deselect and set them.
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Step 4: Click the "Start" button to start processing. After the output window

prompt is completed, DEM will be successfully generated.

2.1.1.4.5. DEM Editor

To produce compliant products，manual inspection and careful editing of DEM

are often required. Here we will introduce the DEM editing process.

CoProcess supports loading large DEM data by DEM Linkage for DEM 2-3D joint

editing. The operation process is as follows:
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Step 1: Open the DEM Linkage. Click "DEM - > Load DEM " to open;

Step 2: Add DEM data to edit. Click "Add" in the lower left corner of the DEM

Linkage dialog box;

Select small DEM blocks in the box for editing. Zoom in and out to view the DEM.

When unqualified places are found, start Rectangular Selection, and left-click two

points in the position to edit to draw a rectangular box. The DEM inside will be

displayed in the main view in 3D form.
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Step 4: DEM selection and editing.

We will combine the two cases to illustrate here, and the operation methods of

other editing commands can be referred to these two cases.

Case 1: As shown in the figure, DEM error caused by building splitting into

ground points appears. In this case, we use the "Adaptive Smoothing" function in

DEM editing to correct the DEM errors within the scope as follows:

1.Click Edit DEM function;
2.Click model selection in the processing tools window on the right;
3.Drawing in the main view will modify the polygon contained in the region,

right-click to end the drawing;
4.Click "Adaptive Smoothing" in DEM edit;
5.Set the Elevation Lift to 0, check the Interpolation edge, and click OK.

As shown, edits from 3d entities are synchronized to the 2D view in real

time.



CHCNAV COPROCESS2.6 USER MANUAL P a g e | 23

Case 2: Aiming at the uneven ground caused by some noise points, DEM can be

leveled by means of the Elevation Smoothing tool.

The operation method is the same as Adaptive Smoothing, and the editing

operation is as follows:

1.Using the model selection to delineate the boundaries of the areas to be
smoothed on the DEM.

2.Click Elevation Smoothing in Processing Tool;
3.Click OK.

Note: DEM editing results will be saved in real time.

2.1.1.4.6. DEM Inspection

After DEM editing is completed, you can use DEM elevation checking tool to

check the quality of DEM editing results.

CoProcess provides a way to evaluate DEM quality using elevation checkpoints:

Calculate the point median error of elevation points so as to evaluate the quality of

DEM.
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2.1.1.5. Results

The results of DEM inspection are the results that meet the requirements.

2.1.2.Contour&Elevation points Generation

The CoProcess software supports the generation of contours and elevation

points from ground points, as well as the direct generation from the existing DEM.

Here we use an existing mountain DEM to generate contours.



CHCNAV COPROCESS2.6 USER MANUAL P a g e | 25

A mountain scene

Step 1: After the “Block” is loaded, click the “Generate Contour” button, and

choose the second option "Generate from DEM" in the “Contour Generation Method”

bar. Then choose an already generated or processed DEM.

Choose a generation method
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Step 2: Click the “Next” button, then set relevant parameters of “Contour

Generation” and “Contour Smooth”. The parameter of “Contour Interval” is set to the

commonly used 2m, and the “Moving Average” and “Simplify Threshold” of the

contour results can be set according to the actual requirements. Here, we choose the

default 5 and 0.1.

Set contour generation parameters

Step 3: After the above parameters are set, click the “Start” button, and the

software will automatically generate the contours of the entire DEM range according

to the parameters set.

After the generation of the contours is completed, they will be automatically

displayed on the view. The yellow contours are the intermediate curves, and the

green contours are the index curves.
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Set contour generation parameters

Step 4: Contour editing: Display the DEM and contours together. If we find there

is something wrong with the generated contours, we can use the processing tool to

repair them.

Press the shortcut key K or click the “Revise” button, then click a few points on

the wrong contours. After double clicking the“OK” button, the newly generated

contours will replace the original wrong contours. If we choose the “Spline Fitting”

option, the repaired contours will be smoother.

Contour revision

For the wrong contours at the boundaries of the DEM due to vertical surfaces,

we can use the break function to delete them. The operation is very simple. Just

activate the break tool and click two points on the two segments of the wrong

contour.
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Or we can use a single point to break. What we need to do is clicking at the

beginning and end of the wrong contour and then using the line deletion tool to

delete the middle part.

Contour break/delete

Step 5: Draw contour notes: After a series of editing operations, there is no

problem with the contours, and the next step we need to do is displaying the altitude

notes of the contours on the contours. We can click the “Mannual Annotation” tool

to draw a straight line on the contour, and then an altitude note will be marked

where the drawn line intersects the contour line, as shown in the following figure:

Contour note drawing
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Step 6: Generate elevation points: After the notes are drawn on important

locations such as ridges by using the above method, it signals that the contour results

generation for this area is completed. Next comes the process of generating

elevation points. The same as the contours, elevation points can also be generated

from both contours and the existing DEM.

Click the “Generate Elevation Point” function, we can choose “Generate from

Point Cloud” or “Generate from DEM” option. Then click “Next” to set elevation

point parameters such as grid interval, elevation point style and so on.

Elevation point generation

After the elevation points are generated, we can see the red elevation points on

the main view, and after opening the “Text Symbol” option, we can see the text

notes of the elevation points.
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elevation point generation

2.1.3. Buildings outline Extraction
2.1.3.1. Sample Data

Demo data in this guide is from Chinese village which is “.las” format with 1.94GB.

Demo is fully based on Terrain module.
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2.1.3.2. Steps in Building outline Extraction

a. Block

b. Filtering (Including Auto Classification)

c. Main-View Manual Classification

d. Buildings outline Extraction

e. Buildings outline Semi-Edit.

2.1.3.2.1. Points Block

Step 1: Add the point cloud file to be processed in the workspace, click the block

button in the terrain module workflow (Figure 5.1), and the block window will pop

up.

Step 2：Set the grid size, block name and save path in the pop-up window. When

modifying the length and width of a block, the size of the grid in the view changes in

real time.

Step 3: Confirm settings and blocking converting.
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Step 4: Load Grid point cloud.

2.1.3.2.2. Filtering

Step 1: Click Filter.

Step 2: Select Filtering block, here we only select left bottom 4 block. If not select,

the default is all of blocks.



CHCNAV COPROCESS2.6 USER MANUAL P a g e | 33

Figure 2- 1 select Filtering blocks

Step 3: click next to set filtering configuration. Please set scenarios by actual terrain,

here we select plane. If users want to classify buildings and vegetation, it’s able to

select “buildings” and “vegetation”. If users want to select proper configuration, it’s

recommended to process small block data for configuring setting parameters. For

Isolated points filtering please select auto calculation.

Step 4: Click next and generate exported point cloud.
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Figure 2- 2 Setting Filtering Setting

2.1.3.2.3. Main-View Classification (Manual Edit)

Auto-filtering does not classify points correctly all the time. Depending on the

computer configuration, you can choose to load one or a few pieces of data for

manual editing. In order to ensure smooth operation, it is recommended to only load

one piece of point cloud data at a time.

Step 1: Load grid point cloud, please follow the the preview (default sampled points)

point cloud and select blocks to show points cloud.
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Step 2: Configure colorization mode, using colorization tool to set

Elevation/Intensity/Classification to load point cloud. We recommend selecting EDL

make texture and shape look better.

Click right icon in shortcut to display different classification. Unselect other and keep

buildings to check if classifying is correct.
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Step 3：Use Main-View Classification to manually edit point cloud class, please follow

the tablet below to input source and target.

Table 2.1 Point Cloud Classification Scenarios

Scenarios Source Target

Wrong Buildings Non/Vegetation/Ground

Missing Non Buildings

Main-View Classification Edit Steps:

a.Click Main-View Classification, set the source and target, here we select them as
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Buildings and Non-Classification.

b.Click Rectangular/Polygon/Brush to select region of interest(ROI).

c.There are reverse/forward option for every step. When you finish one ROI, you can

close the Main-View Classification, and do next ROI.

2.1.3.2.4. Buildings outline Extraction

By editing operations, we can obtain finely classified building point clouds. Here we

will introduce the process of using these point cloud data to extract building outlines.

2.1.3.2.4.1 Single Building Extraction

Step 1: Open the building outline extraction tool. Click "Building Editing—>Quick

Building Extraction" to open the building outline extraction tool, including "Single

Building Mode" and "Multiple Building Mode". Here we choose "Single Building

Mode".

Step 2： In the active view, use the left mouse button to draw polygon areas. After

selecting all the building areas to be extracted, click the right mouse button to

process these chose building areas.



CHCNAV COPROCESS2.6 USER MANUAL P a g e | 38

Select the buildings area

Step 3: Click "Extract" and the software will automatically extract the building outline

of the selected polygon area. After the building outline is generated, it will be

automatically displayed on the view. The outline color is purple.

Buildings Outline

2.1.3.2.4.2 Multiple Building Extraction

Step1: Open the building outline extraction tool. Click "Building Editing—>Quick

Building Extraction" to open the building outline extraction tool, including "Single

Building Mode" and "Multiple Building Mode". Here we choose "Multiple Building

Mode".
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Multiple Mode

Step2: In the active view, use the left mouse button to draw polygon areas. After

selecting all the building areas to be extracted, click the right mouse button to

process these selected building areas.

Select the buildings area

Step3: Click "Extract" and the software will automatically extract the building outline

of the selected polygon area.
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Buildings Outline

2.1.3.2.4.3 Manual Extraction

Step1: Click “Manual Drawing”, and right click "Switch Interaction", and you can

choose "Right angle", "By edge" and "Polygon" to draw. Here, The default drawing

mode is "Right angle".

Manual Drawing

"Right angle" mode

Step2: In the active view, use the left mouse to click two points to determine the



CHCNAV COPROCESS2.6 USER MANUAL P a g e | 41

direction of the first edge, and click on other edges in turn, and then click the right

mouse button for processing;

Right-angle drawing

Step3: Click the “Finish” button to end the drawing process, and the buildings outline closes

automatically.

Buildings outline
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2.1.3.2.5. Buildings Outline Edit

After completing the building outline extraction, manual inspection and detailed

editing are often required to output building outline products that comply with

specifications. Here we will introduce the editing process of building outlines.

To correct some problematic building outlines more efficiently, the software

provides semi-automatic editing tools. The operation process is as follows:

Step 1: Open Semi-auto edit tool shortcut. Click “Buildings Edit”.

Step 2: Edit as different scenes, here is explained by cases.

Case 1: Zigzag building outline correction. For this situation, we use the

""Straightening " function in building editing to correct the wrong contours within the

range. The editing operation is as follows:

a. Click Building Edit.

b. Select the polygon interaction mode in the window processing tools on the

right.

c. Select the ""Straightening " function in editing mode.

d. Draw the polygons contained in the area to be modified in the main view,

double-click the left mouse button to end the drawing, as shown in the figure

the building outline is straightened.
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Case 2: Modification of building outline and elevation. For some situations where

there is a building facade but the outline does not coincide with the facade, we use

the "facade correction" function in the building editor to correct the erroneous

outline within the range to a position that coincides with the facade. The editing

operation is as follows:

a. Click Building Edit.

b. Select the rectangular interaction mode in the window processing tools on

the right.

c. Select the " Facade Correction" function in the edit mode.

d. Draw the rectangle contained in the area to be modified in the main view.

After the drawing is completed, the outline is corrected to a position that

coincides with the elevation.

Case 3: Extend Object Extraction. For situations where the outline does not include
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some rectangular appendages under the eaves such as balconies, we use the

"Extending Extraction" function in the architectural editor to automatically correct

the outline to a vector line containing the rectangular extended object. The editing

operation is as follows:

a. Click Building Edit.

b. Select the rectangular interaction mode in the window processing tools on

the right.

c. Select the " Extend Object Extraction " function in edit mode.

d. Draw the rectangle contained in the modified area in the main view. When

the drawing is completed, the contour line is automatically corrected to a vector

line containing the rectangular extension object.

Case 4: Arc Edge extraction. For the case where the contour line of the arc-shaped

part of the building is incorrectly extracted, we use the "Arc Edge Extraction"

function in the architectural editor to automatically correct the contour line to a

position that fits the arc-shaped building point cloud. The editing operation is as

follows:

a. Click Building Edit.

b. Select the rectangular interaction mode in the window processing tools

on the right.
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c. Select the "Arc Edge Extraction" function in the edit mode.

d. Draw the rectangle contained in the area to be modified in the main view.

When the drawing is completed, the contour line is automatically corrected to a

position that fits the arc-shaped building point cloud.

Case 5: Rectangular Processing.

For situations where the corners of building point clouds or the outline of

extended objects are not right angles, we use the " Rectangular Processing "

function in architectural editing to automatically correct the contours to right

angles. The editing operation is as follows:

a. Click Building Edit.

b. Select the rectangular interaction mode in the window processing tools on the right.

c. Select the "Rectangular Processing" function in the editing mode.

d. Draw the rectangle contained in the area to be modified in the main view. When the

drawing is completed, the outline will be automatically corrected to a right angle.
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Case6: Cutting. By using the “Cutting” function in architectural editing we can cut the

buildings outline into two closed buildings outlines. The editing operation is as

follows:

a. Click “Building Edit”;

b. Select the "Cutting" function in the editing mode;

c. The default cutting width is 0m, and here we set the cutting width as 1.8m;

d. Draw a multi-segment line across the buildings outline in the main view, and double click

to finish the drawing process, then the buildings outline is cut into two closed buildings

outlines.

In addition, if automatic building editing cannot make corrections, you can use

vector editing tools such as trimming, adding points, deleting points, and moving

points to manually edit the building outline. Please select Dot Symbol to show each

point node and edit the outline.
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2.1.3.3. Building Outline Result

After passing the buildings outline editing check, right click the buildings outline

node and select “Export” to export the building outline line as two dimensional

multisegment lines, and then the buildings outline production results meeting the

requirements can be obtained.

2.2. Terra Parameter description

2.2.1. Isolated point (noise) filtering

 Algorithm Principle

Within a certain radius (Search Radius), if the number of neighborhood points of the point is
less than the set threshold, the point is determined as an isolated point.
The parameters in the figure below indicate that within a radius of 0.3m, if the number of
neighborhood points is less than 5, the point is determined as an isolated point.
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As shown in the figure below:The number of neighborhood points of the green point within
radius d is 1, indicating that the green point is an isolated point. The yellow point has no
neighborhood points within the d radius, so it's also an isolated point.

schematic diagram

 Real Scenario 1

The point in the figure below is 1.011m away from closest point.

Set the search radius to 1.0m

Within the radius of 1.0m, the number of neighborhood points is 0, so this point is marked as
an isolated point.
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 Real Scenario 2

Noise is not limited to the isolated single point, for example, isolated point group (2 or more
than 2 points),as in the figure below:

If you want to remove the isolated point group formed by these two points, you can set the
parameters as below:

 Auto Calculate

When you check “Auto Calculate” box, the search radius is 2-3 times the average point
spacing, and the neighborhood points parameter is set to 5. This rule is suitable for most
scenarios.

2.2.2. Low point filtering

 Algorithm Principle
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The parameters in the figure below :

Take a point as the center to search the three points closest to it, including the current check
point, where the height difference between the point with the second largest elevation value
and the point with the largest elevation value is more than 1m, then this point is determined
as the low point.
Due to equipment or working environment, resulting in partial points below the ground
point, which is the low point.
As shown in the figure below: Take the point in the red box as the center to search the three
points closest to it.The height difference between the point with the second largest elevation
value (in the red box) and the point with the largest elevation value (the top point in the
green box) is more than 1.5m, then this point (in the red box) is determined as the low point.

Low point is not limited to the single point but also point group (2 or more than 2 points).It is
recommended to set the “Neighborhood Points”to ≥2 , and set the “Distance Threshold
(m)” to 1m.

1.5m
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2.2.3. Ground point filtering（地面点）

Ground point filtering contains four scenarios:city road, flat ground, hills, mountainous areas.
City hardened pavement:

city road
An area with more gentle terrain:

flat ground

An area with highly undulating terrain:
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hills
An area of very steep terrain with distinct ridges:
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mountainous areas
2.2.3.1. Flat Area

 Description of parameters

1) Max Building Size (m)

The diagonal dimensions of the largest building in the point cloud data.

Parameter setup suggestion:
Generally,set according to the diagonal dimensions of the largest building. If the building
points are misclassified as the ground points, increase the maximum building size.
Notes:
The maximum building size cannot be set too large, the value cannot exceed 1/2 of the side
length of the point cloud data outsourcing box. For example, the size of the point cloud data
outsourcing box is 60m×70m,the maximum building size can be increased to no more than
30m.
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The maximum building size cannot be set too small, the minimum value is generally 10-20
times of the point cloud density.

maximum building size 5m

maximum building size 153m

2) Max Terrain Angle (°)

The angle between the steepest terrain and the ground.
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Max Terrain Angle parameter has great influence on the results of complex mountain terrain.

Max Terrain Angle 25°

Max Terrain Angle 40°

3) Iterate Angle (°)

Refers to the largest Angle of the three angles formed by the point to be inserted to the
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three vertices of the closest triangle mesh. See the angle in the figure below:

Iterate angle 6° Iterate angle 30°

4) Iterate Distance (m)

The iterative progressive triangulation algorithm is a process of gradual encryption, as shown
in the figure below, the principle is that new points are constantly added to the triangle
mesh, we call the triangles in it triangle mesh surface.

Iterate Distance (m)：Refers to the distance between the point to be inserted and its closest
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triangle mesh surface. See the distance in the figure below:

Parameter setup suggestion:
Iterate distance parameter has little influence on the results, which is generally reasonable
between 1.2-2.0m.

Iterate distance 1.2m

Iterate distance 3m

5) Reduce iteration angle when edge less than (m)

When you check “Reduce iteration angle when edge less than (m)” box, ground points

whose distance is less than the set threshold will not continue to generate triangle mesh.

Can smooth the display of ground points.
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Iteration angle length threshold (m)
Parameter setup suggestion:
The larger the iteration angle length threshold, the larger the interval between generated
ground points, and the smaller the number of ground points.
The default value is 2m, which means that the points whose distance is less than 2m will not
continue to generate triangle mesh , so it's not a ground point.

iteration angle length threshold 1 m
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iteration angle length threshold 7 m

not check “Iteration angle length threshold (m)” box

check “Iteration angle length threshold (m)” box

6) Stop triangulation when edge less than (m)

When you check “Stop triangulation when edge less than (m)” box, ground points whose

distance is less than the set threshold will not continue to generate triangle mesh. This can

prevent that the generated ground points are too dense.
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Parameter setup suggestion:

The larger the iteration angle length threshold, the sparser the generated ground

points.

The default value is 2m, which means that the points within the triangle mesh whose

three sides are all less than 2m will not constitute the ground points.

When the “Stop triangulation when edge less than (m)” is not enabled

Stop triangulation when edge less than 1m
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Stop triangulation when edge less than 0.05m

Note: When this parameter is set too large, the ground points will be too sparse, and

some ground feature points will be missing, which will affect the accuracy of the

terrain.

 Parameter setup suggestion

1.Gentle terrain

1) It is suggested that iteration angle be adjusted preferentially, if a large number of

other object points are misclassified into ground points, reduce the iteration

angle , the reverse is also true, the range of each adjustment is recommended to

be 3°.

2) For data with larger buildings, also need to consider the maximum building size,

the diagonal length of the largest building is measured as the input parameter.

3) Because the terrain is relatively gentle, the maximum terrain angle has little

influence on the results, leave this as the default.

2.Non-gentle terrain

1) It is suggested that iteration angle be adjusted preferentially, if a large number of

other object points are misclassified into ground points, reduce the iteration
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angle , the range of each adjustment is recommended to be 3°. The reverse is also

true.

2) The lack of ground points in some steep slope areas is generally due to the small

value of max terrain angle,increase the max terrain angle , the range of each

adjustment is recommended to be 10°. The reverse is also true(For example, there

are a lot of spikes, as shown below).

3) For data with larger buildings, also need to consider the maximum building size,

the diagonal length of the largest building is measured as the input parameter.

Notes:

1) In both cases above, the iterate distance parameter has little influence on the

results, which is generally reasonable between 1.2-2.0m.

2) For point cloud data without buildings, leave the maximum building size as the

default. Other parameters should be adjusted according to the rules above.

2.2.3.2. City Area (Road)
City road classification uses the plane detection algorithm, and classifies the ground points
through the constraints of the number of points, topographic relief and other parameters.
This algorithm is used for local area plane detection, and classifies the inner points of the
plane (if the distance from the point to the plane is less than the distance threshold , it is
called the inner point of the plane) as the ground points, which is applied to the classification
of city hardened pavement of vehicle-mounted point cloud .
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 Description of parameters

1) Near Radius (m)

Neighborhood search radius, used for region growth, as input data for plane detection. For
normal usage, set to 3-5 times the scan line interval. If the value is too small, the inner points
of the plane cannot be correctly detected. If the value is too large, plane detection efficiency
is reduced.
As shown below, the scan line interval of the test data is 0.04m, when set the near radius to
0.04m, the pavement on both sides of the road is not properly classified.

near radius 0.15m
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near radius 0.04m

2) Points Number Threshold

This parameter is used to constrain the number of points of the local plane being detected. If
the number of points is less than this value, the point cloud in this part is discarded.
As shown below, if the value is too small, there will be a smaller set of plane points classified
as ground points by mistake.

Points number threshold 10
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Points number threshold 100

3) Plane Points Ratio

The proportion of points with planar characteristics in a point set is the plane points ratio,
used to determine whether the detected local plane is a valid plane.If the calculated value of
plane points ratio of the detected local plane is greater than the set threshold, the detected
local plane will be classified as the ground points. This parameter is in the range [0,1]. If the
value is set large, some rough surfaces will not be classified as ground points, and the
classification effect will be more refined.

plane points ratio 0.9 plane points ratio 0.5

4) Result Sampling (m)

The distance threshold used to sample the point cloud. On the premise of meeting the
accuracy and density of the result point cloud, thinning the point cloud to improve the
efficiency of the algorithm. When you check “Result Sampling (m)” box, can set the value
according to the desired result accuracy.
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Result sampling 0.05m

Result sampling 0.01m

2.2.4. Key Points Parameter Description

When exporting ground points, the ground points are sampled according to the principle of
preserving as many features as possible to obtain the feature points that can reflect the
fluctuation changes of the terrain.
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1) Percentage of Feature Points (%)

The points are sorted according to the curvature from large to small, and the points with
larger curvature are exported in percentage, which are the feature points.
Parameter setup suggestion:
For normal usage, leave this as the default of 20%, the larger the value, the more points.

Percentage of feature points 20% (613019 feature points)
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Percentage of feature points 80% (1504292 feature points)

2) Sampling Interval (m)

The size of the grid to sample the point cloud.
Parameter setup suggestion:
For normal usage, leave this as the default of 2m, the larger the value, the less points.

Sampling interval 2m (613019 feature points)

Sampling interval 6m (386666 feature points)
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2.2.5. Contours Generation

 Contour Parameter Settings

1) Grid Interval (m)

Generate contours using DEM automatically.( Set according to the actual accuracy)

2) Minimum Elevation (m)

Minimum elevation value of point cloud data.( software automatically obtains this value)

3) Maximum Elevation (m)

Maximum elevation value of point cloud data.( software automatically obtains this value)

4) Contour Interval (m)

The actual height difference between the two contour surfaces.

5) Length Filter (m)

When generating contours, there are some little mounds or buildings on the ground,
but these are not actual, real terrain, so need to set the this parameter to filter.
There are generally two types of abnormal contours that need to be filtered, Circles
and short lines,as shown below:
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Before filtering

After filtering
Results show:
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2.2.6. Contours Smooth

The contour smoothing function is mainly used to generate smooth contours.

Based on the already generated contours, we can use these contour smoothing

algorithms shown in the following figure(including moving average, tension spline fitting

and spline fitting) to smooth the contours. The moving average algorithm is selected by

default.

1) Moving Average

[Description]: The center point is smoothed by several adjacent points.
[Parameter Setting]: The default number of the neighbor points is 5, that is 2 points on each
side plus 1 center point. This parameter can only be set to an odd number greater than or
equal to 3.
[Applicable scenes]: Contours with dense vertices, such as contours generated based on the
DEM with 0.5m resolution.

2) Tension Spline Fitting

[Description]: The center point is smoothed by spline interpolation between two adjacent
vertices.
[Parameter Setting]: Not required.
[Applicable scenes]: Contours with sparse vertices, such as contours generated based on the
DEM with the resolution greater than or equal to 5m.

3) Spline Fitting

[Description]: Contours are automatically segmented, and for each segment a cubic spline
function is used for fitting. The purpose is to smooth the center vertex and to keep the
connection of each segment smooth.
[Parameter Setting]: Not required.
[Applicable scenes]: Contours with sparse vertices, such as contours generated based on the
DEM with the resolution greater than or equal to 5m.

4) Not Fitting

[Description]: The contours result are not smoothed.
[Parameter Setting]: Not required.
[Applicable scenes]: Contours generated based on control points.
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We have generated contours based on airborne point clouds, and in the following we
will use this as an example to show the effects of each algorithm:

Input point cloud and the effect of not fitting method (Partial display in red box)

Not fitting (Partial display in red box)
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Moving Average (Partial display in red box)

Tension Spline Fitting (Partial display in red box)

Spline Fitting (Partial display in red box)

2.2.7. Elevation points Generation

[Principle]: Elevation points are obtained by sampling the point cloud at a certain distance,
and they can can reflect the elevation change of the scene.

[Parameter Setting]

1) Points Type

You can select the ground points or all points, and the ground is selected by default.

2) Elevation Point Style

The shape of the sampling points distribution, and now it supports both square and diamond
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shapes.

3) Grid Interval (m)

The interval of the sampling points distribution.

square
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Diamond

2.2.8. Contours Simplify

Contours simplify setting
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[Simplify Threshold (m)]: The distance between the current point and the two points around

it in a straight line.

[Parameter Setting]: The default value is 0.1m, and the recommended value range is
[0.05,0.1]. Actually the value can be set from 0.01 to 1.

[Applicable scenes]: For contours with dense vertices, this algorithm is used to reduce the

number of vertices. The specific performance is as follows. Very few points are retained in

the flat region, and if some points form a collinear segment, only the two endpoints of this

line segment will be preserved. In the region with large fluctuations, more corner points can

be preserved to ensure that the basic shape remains unchanged.

The following is the simplification effect of a dense contour with the default simplify

threshold of 0.1m.

The smaller this parameter is set, the more points are retained and the contours are
smoother, but at the same time the size of data will be relatively larger.

0.2m
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0.1m

0.05m

0.01m

Nonuse simplification

2.2.9. Generate elevation points

Elevation points are obtained by sampling the point cloud at a certain distance, which can
reflect the elevation changes of the scene.
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5) Points Type

You can select the ground points or all points, the ground is selected by default.

6) Elevation Point Style

The shape of the sampling points distribution, now supports both square and diamond
shapes.

7) Grid Interval (m)

The interval of the sampling points distribution.

square
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Diamond
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2.2.10.Building Filtering

Figure : Buliding Filting - parameter settings

2.2.10.1.Distance from ground

The height of the lowest point of a building from the ground is mainly to avoid the impact of

plane points close to the ground (such as cars, small rocks, etc.) on the subsequent

extraction results of building contours.

Parameter settings:

The default value is 1.2. The value range is [0.1,3]. The recommened value range is [1,2.5].

If the scene is a low rural house, this value can be set to 1.2; The height of urban buildings is

generally above 3m, and this value can be set to 2.5 to ensure the accuracy of building

contour extraction.

Note: Setting this parameter will result in missing points at the bottom edge of the building,

but it has little impact on building contour extraction.
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Figure: Distance from ground is 1.2 meters

Figure: Distance from ground is 2.5 meters

2.2.10.2.Maximum normal angle

The angle value between the normals of adjacent points in a single building. The rougher the

building surface, the larger the value; the smoother the extracted building surface, the

smaller the value. If the value is set too large, some building accessory points will be

mistakenly classified into building points. The parameter value needs to be adjusted

according to the actual situation.

Parameter settings:

The default value is 6° . The value range is [1,30], which must be set according to the

thickness of the roof point cloud.

The current recommended values are as follows:
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When the building surface is rough and uneven and the thickness of the point cloud is about

4-6cm, the value can be set to 6; When the thickness is greater than 6cm, the value can be

set to more than 6;

When the thickness of the point cloud is about 2-3cm, the value can be set to 3;

When the building surface is smooth and the thickness of the point cloud is below 2cm, the

value can be set to 1 or 2;

The rougher the building surface, the larger the value; the smoother the extracted building

surface, the smaller the value. If it is found that there are many points on the roof of the

building that are not correctly classified, the value needs to be appropriately increased by

1-2°.

The thickness of the roof point cloud can be measured through the section view, as shown in

the figure:

Figure: the thickness of the roof

There are multi-layer point clouds on the roof here, the thickness is also 5-6cm, and the data

is relatively rough. At this time, the maximum normal Angle is set to 6° .
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Figure: Maximum normal angle is 6°

Figure: Maximum normal angle is 3°
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Figure: Maximum normal angle is 1°

2.2.10.3.Maximum point spacing

The maximum distance allowed between adjacent building points controls the integrity of

building extraction.

Parameter settings:

The default value is 1.5. The value range is [0.2.6]. The recommened value range is [1,1.5].

The parameter setting should also refer to the point spacing of the building surface, if the

setting is too small, the building extraction will be incomplete, and if the setting is too large,

the two buildings that are closer together will be mistakenly divided into one.
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2.2.10.4.Minimum number of individual points

The number of points occupied by the smallest building in the actual scene, which is the

minimum number of points required to form a single building. Buildings with fewer points

than the set value will be discarded. By setting this parameter, some ground objects that are

mistakenly divided into buildings, such as vehicles with fewer points, shrubs, etc., can be

removed.

Parameter settings:

The default value is 500. The value range is [20,2500].

By measuring the point density and the projected area of the building, the number of points

of a single building can be estimated by multiplying the results of the two. The minimum

number of points of a single building can be set according to the actual needs.

2.2.10.5.Minimum area of individuals

The number of points occupied by the smallest building in the actual scene, which is the

minimum number of points required to form a single building. Buildings with fewer points

than the set value will be discarded. By setting this parameter, some ground objects that are

mistakenly divided into buildings, such as vehicles with fewer points, shrubs, etc., can be

removed.



CHCNAV COPROCESS2.6 USER MANUAL P a g e | 86

Parameter settings:

The default value is 16. The value range is [1,40].

Figure: Actual measured area

Figure: Minimum area of individuals is 16, not classified as a building
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Figure: Minimum area of individuals is 6, classified as a building

2.2.11.Vegetation Filtering

Figure: Vegetation Filtering - parameter settings

2.2.11.1.Minimum normal angle

Unlike building filtering, vegetation filtering is extracted according to surface roughness, so it

is necessary to limit the minimum normal angle between adjacent vegetation points. The

rougher the surface, the larger the setting value; The smoother the surface, the smaller the
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setting value.

Parameter settings:

The default value is 6. The value range is [1,30]. The recommened value range is [6,10].

The larger the value is, the more vegetation is to be omitted in classification. The smaller the

value, the more surface will be mistaken for vegetation. If it is found that the surface is

misdivided into more vegetation, it is appropriate to increase 1-2°.

2.2.11.2. Maximum point spacing

The maximum distance allowed between adjacent vegetation points. Mainly affects the

integrity of vegetation classification. Setting it too small may result in incomplete extraction

of individual vegetation, while setting it too large may cause adjacent unclassified points to

be mistakenly divided into vegetation.

Parameter settings:

The default value is 1.2. The value range is [0.2,6]. The recommened value range is [1,1.5].

The parameter setting should also refer to the point spacing of the vegetation. Take the

maximum distance between the points.
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2.2.12.Extracting building Outline

Figure: Extracting building Outline - parameter settings

 Minimum number of individual points

The number of points occupied by the smallest building in the actual scene. Buildings with

fewer points than the set value will not be extracted with outlines.

Parameter settings:

The default value is 500. The value range is [20,2500].

By measuring the point density and the projected area of the building, the number of points

of a single building can be estimated by multiplying the results of the two. The minimum

number of points of a single building can be set according to the actual needs.
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 Minimum area of individual

The projected area of building in the actual scene, and buildings with an area smaller than

this value will not extract outline.

Parameter settings:

The default value is 40. The value range is [1,40].

Figure: Actual measured area

Figure: Minimum area of individuals is 16, no outline was extracted
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Figure: Minimum area of individuals is 6, outline was extracted

[Buildings outline extraction - Parameter Description]:

Buildings outline extraction parameters

 Minimum length of the attachment

It refers the minimum length of the rectangular building attachments in the actual scene.

When extracting the buildings outline, the outline of the part of the building attachment

whose length is less than this set value will not be extracted.

Parameter settings:

The default value is 1.0m, and the value range is [1,2]. In the actual setting, you can set it

according to the actual length of the attachment.

 Minimum depth of the attachment
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It refers the minimum allowable depth of a rectangular attachment. When extracting the

buildings outline, the outline of the part of the building attachment whose depth is less than

this set value will not be extracted.

Parameter settings:

The default value is 0.2m, and the value range is [0.2,0.5]. In the actual setting, you can set it

according to the actual depth of the attachment.

Rectangular attachment
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The parameters of the rectangular attachment

The extraction effect of the default parameter
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The minimum length of the attachment is 3.8m

The minimum depth of the attachment is 0.9m

 Simplification degree

It refers the maximum allowable distance between two adjacent approximately parallel

outlines. If the actual distance is bigger than this set value, a short edge will be added

between the two parallel lines.

Parameter settings:

The default value is 0.2m, and the suggested value range is [0.1,0.5].

As the following picture shows, the default simplification degree is 0.2m, but the distance

between the two adjacent lines in the picture is 0.3m, which is bigger than 0.2, so at last

there is a short edge between the two lines. When the simplification degree is adjusted to

0.3m, then the short edge will disappear.
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The simplification degree is 0.2m

The simplification degree is 0.3m

 Eave correction

This option is not checked by default, and you can choose whether to check it according to

the actual requirement. If not checked, the building outline is extracted to the edge of the

point cloud of the building, such as the eave; If checked, when the building has a elevation

point cloud, the building outline will be extracted to the building elevation.
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Eave correction

 Rectangularization

This option is not checked by default, and you can choose whether to check it according to

the actual requirement. If checked, the extracted building outline is forcibly converted into a

rectangle.

Rectangularization

2.2.13.Buildings Editing

[Parameter description]:
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parameter

[Cutting width]: It refers to the distance between the outlines of the two adjacent buildings

after the cutting operation.

[Cutting width-Parameter setting]: The default value is 0, the range can be set is [0,100);

When setting the cutting width, we can set the cutting width according to the actual

requirements. When the cutting width is set to 0, the outlines of the two buildings after

cutting coincide at the cut line. When the cutting width is set to another value, they do not

coincide, and at this time we can edit and revise the outlines of the two buildings

respectively.

When the cutting width is set to 0m, after cutting the outlines of the two adjacent

buildings coincide at the cut line; When the cutting width is set to 0.7m, the extension width

to both sides is 0.7m take the cutting line as the center line, and the outlines of the two

buildings are 0.7m apart from the position of the cutting line.



CHCNAV COPROCESS2.6 USER MANUAL P a g e | 98

The cutting width is 0m

The cutting width is 0.7m

Note: When setting the cutting width, do not exceed the width of the building outline.

2.3. Roads User Guide

2.3.1. Introduction

This document aims to provide technical guidance for users using CoProcess

software on the process of road section extraction, and briefly show the whole

process of section generation and editing.

This document does not involve detailed explanation of specific functions. If
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necessary, please refer to CoProcess User Manual.

2.3.1.1. Sample Data

The sample data used in this demonstration is the point cloud data of a road

planning project in a mountainous area, including piles, straight curve tables, point

clouds, chain breaks and other documents in the design. The length of the road is

about 16 kilometers.

The section production process is mainly divided into the following steps:

 Import point cloud;

 Get pile;

 Generate profile section;

 Profile section editing (optional);

 Generate cross section;

 Cross section editing (optional);

 Export results;

 Generate Section view.

The production flow chart is as follows:
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2.3.2. Step-by-step

2.3.3. Import Point Cloud

After a new project is created, the cloud must be imported to the ground in the

road engineering area. The Road module now supports the simultaneous processing

of point clouds with large amounts of data using codata format point clouds. Here we

load the sample codata data into the project.
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As shown in the figure below, the yellow point cloud icon is the codata point

cloud file.

2.3.4. Obtain pile by pile

After the point cloud is imported, the road section needs to be extracted by pile.

There are three main methods to obtain pile by pile by CoProcess software: vector

line transformation, flat curve calculation and direct import. This section briefly

describes each of these methods for getting a pile.

2.3.4.1. Vectoring and driving piles

The function of vector line to pile is to generate pile by pile by importing vector

line externally or drawing vector line manually when there is no pile or flat curve in

the design.
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The operation process is as follows:

1) Click the function of "vector line to pile" in route analysis;

2) Select load from node or load from file. Here we select the local dxf file, so

click "Load by File" and then select the road dxf curve;

3) Keep the default values for other parameters and click Execute.

After execution, the pile generated by the local vector line is mounted to the

project.

Click the Horizontal Curve in Road Prase, click Load data in the Intersection

method, open the corresponding JD data, and then click the Route Calculation, the

content of the dialog box will jump to the route page.

Click the Route Create, the corresponding road map and node will appear in the

route node under the project.
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2.3.4.2. Flat curve calculation pile by pile

When a road design document is available, the route calculated by the flat curve

can be used to generate pile-by-pile. CoProcess supports the analysis and route

calculation of intersection method and element method flat curve data. This paper

introduces the method of calculating pile by pile by taking the intersection method

as an example.

The operation process is as follows:

1) If there is a chain break in the designed road section, click the chain break

function in route analysis to import the broken chain;

2) Click the flat curve function in route analysis to open the "intersection

method" on the first page;

3) Click the "Load data" button below to select the local intersection method

route resolution file;

4) Click Calculation, and the dialog box jumps to "Route" on the third page. At

this time, the software has parsed the input file into a route;

5) Click "Pile by pile" on the fourth page of the dialog box, and click "Generate

pile Number" below;
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6) After setting the pile distance, click "pile by pile" to calculate "pile by pile";

7) Finally, click Draw pile by pile to mount pile by pile to the project.

2.3.4.3. Direct import pile by pile

If there is already designed pile by pile, it can be directly imported into the

project and used to generate sections.

Right-click the pile-by-pile node of the road project and select the "Import"

function in the menu to import the local pile-by-pile file into the project.

Note:

(1) When importing the pile-by-pile files in the formats of txt, csv, dat, tmx or route you need

to adjust the data type of each column to avoid errors when calculating the sections.

(2) When importing the pile-by-pile files in the dxf format, the Auto 2000 and/LT2000 version

is required and the layer name should be DMX or dmx.
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After the pile-by-pile file is obtained by the above three methods, the

pile-by-pile file will be mounted to the "pile-by-pile node" of the project, and then

the pile-by-pile file will be used to extract the section.
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2.3.5. Pile Add(Not Necessary)

If some pile points in the automatically generated pile by pile do not meet the

requirements of the generated section, we can modify the pile by pile mounted in

the project by manual piling method.

The CoProcess software supports two manual piling methods: view piling and

mileage piling. Here we take view piling as an example to demonstrate the method of

piling.

The method of piling is as follows:

1) For the convenience of browsing, we first convert the two-dimensional pile by

pile into three-dimensional pile. Use the "Generate pile by pile" in the "longitudinal

section" function to generate the 3d version of the current pile by pile;

2) Click "View piling" in the drop-down list of manual piling function;

3) Enlarge the view, find the place where the pile needs to be added, and click

the left mouse button there to generate a temporary pile point;

4) Repeat the above operation until all pile points are added. Click Export to

save the pile adding information to the current pile by pile.
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In addition:

The mileage piling function does not need to click the position of the piling

point in the view, and directly input the piling number in the dialog box to add the

piling, but it needs the route analysis results to get accurate results.

2.3.6. Generate Section

Profile Secion

1.Import route point cloud and 2D pile-by-pile file;

2.Click the road module -> Road Survey -> Profile Section;

3.Setting whether the features are simplified, click ProfileSection or RoutePiles.

RoutePiles means generating 3D pile-by-pile.

As shown in the figure above, purple dots and yellow tracks represent the

resulting longitudinal section on the point cloud.
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Cross Secion

Click Road survey -> Cross Section to Setting the section parameters.

After there is no problem in section preview, click Generate to extract and

calculate section feature points.
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2.3.7. Vertical section editing

The current algorithm cannot guarantee the accuracy of the automatically

extracted longitudinal section, so we need to check and edit the longitudinal section

manually. The following is an introduction to the relevant precautions for vertical

section editing:

1) Click the "longitudinal section Edit" button, the software will create a

longitudinal section edit window, and display the section line and point cloud

between the first two pile points in the section window;

2) Use the switch button or shortcut key ← or → to switch some sections

currently displayed;

3) When editing the section, you can use the shortcut keys A, D, M, Shift+D to

activate the functions of point, delete point, shift point and batch delete point, and

you can also use the shortcut key G to hide/show the grid.
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The vertical section edited pile points are automatically saved to the currently

loaded pile by pile, and this temporary pile is also written to the pile by pile folder

within the project after saving the project.

2.3.8. Edit Section

Click the Section Editing function, a cross-sectional editing window will appear.

According to the cross-sectional picture displayed in the cross-sectional editing

window, find out the incorrect place and use the shortcut function bar of

cross-sectional editing to modify it.
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2.3.9. Vector Editing

Vector line editing is the editing function of line and section. Click the

drop-down box of vector line editing, many editing functions will appear. If you select

the desired function, you can edit the line and section.

2.3.10.Exporting Survey Results

Click the section to be exported, select the category to be exported, and change

the file name to export the section.

2.3.11.Generate Section View

1. Click the function of generating sectional view;

2. Click Import file and select HDM file;

3. Modify the drawing base point and spacing, right click on a section can set

its pile number as the starting pile number or the end pile number;

4. Set the output path;

5. Click "Cross section Design Drawing" after setting.

After drawing, you can find the drawn DXF file in the output path.
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2.4. Volume User Guide

2.4.1. Introduction

This document is intended to provide technical guidance for the production process of

single-phase volume, Multi volume and Bench line extraction for users using CoProcess.

Taking point cloud data in a mining area as an example, this document briefly shows the

whole process from data import, volume calculation to output results.

This document does not involve detailed explanation of specific functions. If necessary,

please refer to CoProcess User Manual.

2.4.2. Sample data

The sample data used in this demonstration is the two-stage LAS point cloud collected

by UAV in a mining and mountain area.
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2.4.3. Work Flow

The production process of volume production using CoProcess is shown as follows:

CoProcess software supports the generation of volume results such as single-phase

volume report, multi contrast volume report, and special vector line.

This paper will introduce the processing methods of several classic cases, such as

projection volume calculation, two-phase volume comparison report generation,

two-phase change analysis and calculation, and slope top and slope bottom line extraction,

to guide users to use CoProcess software for production.
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2.4.4. Preprocessing

Before the volume calculation, a series of processing of the input point cloud is needed

to finally get the triangulation network that meets the requirements, and then the

triangulation network can be used to calculate the corresponding results. This section

describes how to preprocess data.

Preprocessing is mainly divided into two parts: point cloud processing and triangulation

network processing.

Point cloud data processing and networking

Firstly, the point cloud data to be processed is imported, and the point cloud with

qualified quality is obtained through filtering and compression function. Then use the

"Vector Line Processing" function to import or draw the boundary vector line of the region of

interest;

Using the "TIN" function, select "Add DXF" in the parameter Settings, and select the

vector line "VectorLine1" just imported in the second list.
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Click OK to generate a triangulated network with vector line 1 range constraints. The

next step is to triangulate the triangulation network "Data1_tin" to do the volume

calculation.

Triangulation filtering

Click "Filter" function in "TIN Edit" module, select the triangulation "Data1_tin" in the

pop-up dialog box, and click " Detection";
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As shown in the figure, the surface that exceeds the edge length threshold of the

triangulation network is detected. Click OK. You can delete these large pieces.

Hole Filling

After the triangulation filtering, it is necessary to fill the holes in the triangulation

network to repair the false deletion phenomenon that may exist in the previous step of

filtering.

Click the "Hole Filling" function in triangulation editing, select the filtered triangulation

"Data1_tin" in the pop-up dialog box, click OK button, the software will detect the boundary

in the currently selected triangulation and display it in the second dialog box.

As shown in the figure above, the software detects only one boundary in Data1_tin,

that is, there are no holes inside to fill. From here we can exit the hole filling function and

click "Cancel".

Note: If the software does not detect internal holes, there is no need to perform hole

filling on the triangulation.After the processing is completed, click “Finish” to exit Wizard.

Smoothing

Some sharp terrain bumps will affect the result of the volume calculation, so before
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calculating the volume, one more smoothing operation is needed.

Click the "Smooth" button in TIN editing, and select the triangulation to be smoothed in

the dialog box that pops up, and click OK. The default smoothness parameter is 1. The larger

the value, the better the smoothing effect will be.

After smoothing, if the triangulation network does not meet the requirements, you can

adjust the parameters and edit the triangulation network again.

At this point, the data preprocessing part is over, and we have obtained the

triangulation network that can be used to calculate the volume. The following sections

briefly introduce the operation steps of each process based on different data results.

Note: It is recommended to follow the process of filtering - hole filling - smoothing for

triangulation network, otherwise it is easy to produce wrong results.

2.4.5. Projected Volume Calculation

The process of projection volume calculation using CoProcess can be divided into the
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following four steps: 1) Setting the reference surface; 2) Projection to the reference plane; 3)

Projection volume calculation results; 4) Export reports. The basic operations of this process

are described in detail below:

Step 1: Set the reference surface.

Click the Reference Surface Settings button to open the Reference Surface Settings

toolbar. Here we use the first function button "Elevation Reference Surface" and click a point

on the triangulation or point cloud to create a reference surface with the elevation of that

point.

As shown in the figure, the light gray plane is the reference plane.

Step 2: Project to the reference surface.

To calculate the projection volume, you need to create a projection triangulation based

on the current reference surface.

Click the function of "Project to reference plane" and select the triangulation network

to be projected in the pop-up dialog box to project it to the reference surface.
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The gray boundary as shown in the figure is the projection part of the projection

triangulation. Then, the projection volume of the region of interest can be obtained by using

the Projection Volume Calculation function.

Step 3: Calculate the projection volume results.

After the projection triangulation network is successfully acquired, the computation
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function can be used to calculate the projection volume of the triangulation network

Click the Projection Volume button in the Single Phase Volume, select the "Data1_tin_

Projection" triangulation in the pop-up dialog box, and click Calculate.

After the calculation is complete, a results verification window will pop up, where you

can confirm the calculation results and modify the title of the report. Here, for example, we

changed the report title in the output Settings to " Volume Reoprt."

You can also view the calculated pile, fill and volume calculation results.

Step 4: Generate reports.

After the results are confirmed, click "Export" on the interface to automatically generate

and open the report of projection volume calculation, and mount it on the achievement

node in the project.
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The volume calculation results can be obtained by filling the output report with the

information of the tabulator.

Step 4: After the block conversion is completed, a prompt will pop up whether to load

the block point cloud. Click "Yes" here for better subsequent operations.

2.4.6. Volume Comparison

Before using the two-phase volume comparison, the triangulation data of the

two-phase region of interest should be obtained through the preprocessing function. After

processing the triangulation data, the software will automatically calculate the comparison

of filling and digging square, average elevation, three-dimensional area and other

information of the two stages in the area by using the function of two-stage comparison

calculation. Let's briefly introduce the process of operation.

Step 1: Preprocess.

According to the preprocessing process in Section 4, the qualified triangulation data of

the two periods before and after are obtained.

Step 2: Data calculation.
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Click the volume comparison function in the two-phase comparison, and check the

triangulation network in the first two dialog boxes, and the constraint vector line in the third

dialog box.

After selecting the corresponding data, click Calculate to generate a data test box just

like the projection volume calculation. You can check the calculation results and edit the

report information. In addition, when selecting vector lines here, multiple vector lines can be

selected at the same time, and the change information in the corresponding region will be

counted together.

Here, we changed the title of the report to "two-period comparative calculation", and

modified the starting date and the property of the measured area of the calculation data of

the area code of the vector line.
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After confirming everything, click the "Apply" button.

Step 3: Output the report.

After confirming all the information, click Output Report to generate a two-period

comparison report in XLS format. All the areas contained in the selected vector line will be

calculated and exported together.

You can find the output report under the project node, right click to view the saving

path.

2.4.7. Change Analysis

Two-period change analysis was carried out to analyze the point clouds of two periods

before and after the same position, and to obtain the information such as the thermal map
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of earthwork change and the filling and digging line. Therefore, the method introduced in

this section does not require the previous complete data preprocessing process, and only

needs to process the point cloud data of the two periods.

The process of generating results of two-stage change analysis mainly includes the

following five steps: 1) Selecting data; 2) Calculate the diff map; 3) Report export; 4) Change

area detection; 5) Vector export. The following is a brief introduction to these steps and the

corresponding operation method.

Step 2: Calculate the diff map.

After confirming the selection of the point cloud and the constraint area, click the OK

button. After the progress bar is completed, the software will generate a thermal map of the

earthwork changes in the working area. The default is the red-blue band change, that is, the

parts with large changes are rendered as red and blue, and the parts with small changes are
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rendered as green/yellow in the middle.

Click the Render adjustment function in the two-phase comparison to modify the color

band and range of the thermal map rendering. It can do not pay attention to parts of the

region with large and small changes, and focus on the analysis of regional point clouds with

changes within the set range.

Step 3: Export the report.

After adjusting the rendering mode of the thermal map area, click the "Report Export"

button in the Change Analysis and calculation dialog box to generate the report of volume

contrast change of two periods with one click.

The software will automatically calculate the length of the stack, the width of the stack,

the area of the filling square, the volume of the filling square and other information of the

comparison between the two periods, and output it in the report.
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Right-click the corresponding report to find the saving path of the report.

Step 4: Change area detection.

After calculating the volume change of the two periods, the current point cloud area

can be detected, and the construction line filling and digging can be extracted.

Click the "Change Area Detection" button under the change analysis dialog box to

extract the line filling and digging in the construction area with one click. Meanwhile, manual

editing and deletion of these vector lines are supported.

The blue vector line is the add line, and the pink one is the cut line.
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Step 5: Vector Export.

After the vector editing operation for add and cut lines is completed, select the filling

and digging lines, click the "Export Vector Line" function in vector line processing, and select

the export path to complete the export of vector lines.

2.4.8. Bench Lines

The extraction function of bench crest and bench toe depends on the triangulation

network generated by preprocessing. The extraction process is mainly divided into the

following steps: check the model, set parameters, perform extraction and vector export. The

following is a brief description of these extraction processes:

1. Through data preprocessing, the triangulation network of the region of interest is

obtained.

2. Click the slope top and bottom line extraction in the vector results, and select the

triangulation network to be extracted in the pop-up dialog box;

3. Set the slope Angle threshold and smoothness threshold, and click Execute.
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4. Close the extraction dialog box and select the vector line to be exported under the

vector node in the workspace.

5. Click the function of vector line export in vector line processing;

6. Set the export path and click Start to generate the DXF results extracted from slope line.
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3. Software UserManual

3.1. File&Project
File and Project include workspace opening and saving, point cloud and model import, point
cloud export, terrain module conversion, point cloud storage conversion and system
parameter setting.

3.1.1. Open Resources

Description
Open the saved workspace, and the point cloud or model data in the workspace will be
loaded automatically.
Steps

 Click File and Project -> Open Resources, select the CoPrj file, and click Open.

3.1.2. Save Resources

Description
After saving the workspace, it is convenient to directly open the workspace next time to load
point cloud, model or vector data.
Steps

 After importing point cloud or model data, click File and Project -> Save Resources,

select the save path, enter the file name, and click Save.

3.1.3. Open Point Cloud

There are three ways to open a point cloud:

 Click File & Project -> Open Point Cloud to import data;

 Right-click the point cloud node in the resources to import the point clouds.

 Drag the point cloud file into the view to load and display.

The icon of the external memory point cloud is yellow , and the icon of the memory point

cloud is orange
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3.1.3.1. Open by File&Project

3.1.3.1.1. Open las

Description
Open the point cloud data in las format and display it in the view.
Steps

 Click File and Project -> Open Point Cloud, select the las format, and click Open.

 The las import setting dialog box pops up, where you can view the number of point

clouds and set the thinning option. By reading the las point cloud file information, the

coordinate, intensity and category field information is loaded by default, and the user

can check other attribute fields that need to be imported.

 Clicking Apply only takes effect for a single las data setting. If you import multiple pieces

of las data, you need to execute Apply All to take effect for the selected las file, and load

and display the las point cloud into the 3D view.
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Notes
Only support opening las format point clouds of version 1.4 and below.

3.1.3.1.2. Open ASCII

Description
Open point clouds by ASCII (*.txt, *.pts, *.csv, *.asc, *.xyz) format.
Steps

 Click File and Project -> Open Point Cloud, select ASCII format point cloud, and click the

Open button.

 In the interface of importing ASCII, the default import is point cloud object, and the

separator can be freely selected according to the data format.
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As shown in the figure above, information such as X coordinate, Y coordinate, Z coordinate, R
component, G component, B component, Nx component, Ny component, Nz component and
intensity are automatically assigned to each column of ASCII text data. If the data in the first
column has other information, you need to ignore it; if you import control vector, you need
to select the "target number" attribute in the first column.

 To import ASCII text files in batches, click Apply All to import data in batches.

3.1.3.1.3. Open e57

Description
The E57 format is a file format specified by the ASTM International Standards Organization,
and is an agreed transfer format for point clouds, images, and 3D imaging systems acquired
by laser scanners and other equipment.
An E57 file is a 3D image file created according to the ASTM E57 format, a format used to
store data captured by a 3D imaging system.
The software supports opening *.e57 laser point cloud files.
Steps

 Click File and Project -> Open Point Cloud to pop up the Open Data interface;

 Select the point cloud in *.e57 format, click the Open button, and the point cloud data

will be loaded and displayed in the view.
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3.1.3.1.4. Open codata

Description
Open the *.codata point cloud and display it in the view. The codata point cloud is a data
type customized by the CoProcess software and supports massive data loading.
Steps

 If there is codata data, click File and Project -> Open Point Cloud, and select single or

multiple codata files to load.

 If it does not exist, select the las file, load the conversion settings interface, select

different properties, and click the Apply or Apply All buttons. Start the las conversion

codata process, and load and display the codata data after the conversion is complete.

Notes

 The view currently supports loading a maximum of 1024 codata files, that is, a

maximum of 300G external storage point clouds can be loaded and displayed at the

same time.

3.1.3.2. Open by Resources
Description
The resources loads point clouds in las, ASCII, e57 and codata formats.
Steps

 Right-click the workspace -> Browse Project -> Point Cloud Node, left-click to select and

click to open the point cloud, as shown in the figure.
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 Select las, ASCII, e57 or codata format to load the point cloud to the view, and at the

same time import the data and mount it to the point cloud node.

3.1.3.3. Open by Drag
Description
Drag the las or codata format point cloud into the view to load. When dragging the las point
cloud, it will be directly imported into las or converted to codata according to the import
point cloud setting in the system settings.
Steps

 Select one or more las or codata point clouds, hold down the left mouse button and

drag the data into the view. Pop up the left button to load and display the point cloud.

3.1.4. Open Model

Description
Load and display the model data such as osgb.
Steps

 Click File&Project -> Open Model, select the osgb 3D model file, and click Open to

display the progress of importing the model. The import is successful and the model is

displayed in the view.
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 Click to open the model, select the xml file, and click Open to load the model data.

3.1.5. Export Point Cloud

3.1.5.1. Export las
Description
This function support exporting and saving the las or codata point clouds.
Steps

 Select the point cloud object, click File & Project->Export Point Cloud; or right-click the

point cloud object in there sources and select the Export Point Cloud .

 Select the save path, select the save type *.las, enter the file name, and click the save

button.

3.1.5.2. Export ASCII
Description
Export ASCII( *.txt, *.pts, *.csv, *.asc, *.xyz) point clouds .
Steps

 Select the point cloud, click File and Project -> Export Point Cloud.



CHCNAV COPROCESS2.6 USER MANUAL P a g e | 137

 Select ASCII (*.txt, *.pts, *.csv, *.asc, *.xyz) as the save type, click Save, and the

interface for saving ASCII point cloud will pop up.

You can choose three types of separators: comma, space and Tab key. Choose whether to
output intensity values, RGB values, and add prefixes according to your needs. After the
selection is complete, click Export to save the point cloud in ASCII format to the specified
path.

3.1.6. Convert Terrain Model

Description

Digital terrain model with projection information is generated according to the image
information of the DOM and DEM.
Steps

 Click File and Project -> Terrain Model Conversion to load the conversion interface.

 Select the DEM and DOM images, set the model fineness, select the model output path,

and click Execute to generate a 3D model.
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 Click to open the model, select the generated osga data, and click Open to load and

display the model.

Settings
Model fineness: The default is 8, and the value range is 3-15. The model fineness is related
to the resolution of the DOM and DEM. The higher the resolution, the more fineness levels
can be selected. The higher the fineness of the model, the clearer the generated model, the
larger the amount of data, and the longer the time-consuming.

3.1.7. Convert Codata

Description
The point cloud external memory conversion function is to convert the las point cloud into a
codata format point cloud.
Steps

 Click the covent codata, as shown in the figure, pops up the point cloud conversion

interface;
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 Click "Add Las Path" and select the path of one or more LAS files to be converted.

 Click on Expand Settings to select the properties field to retain when converting. By

default, coordinates, intensity, category, and GPS time are reserved.

 Click the Execute button to start the conversion, and the progress bar will display the

conversion progress in real time.

 After the conversion is completed, the corresponding prompt message will pop up.

Save To the Original Path:
When selected, the codata generated by the conversion will be stored in the path of the
original LAS. If you do not select this parameter, you need to manually set the saving path for
the codata file.

Notes
External memory conversion function, only supports las format point cloud conversion.

3.1.8. System Settings

3.1.8.1. Save Settings
Description
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Set the software automatic saving interval and log saving path.
Steps

 Set the automatic save time: The default automatic save interval is 20 minutes. If you

need to modify it, enter the save time and click the OK button to take effect.

 Set log path: select the path and click the OK button to take effect.

3.1.8.2. View Settings
Description
This function sets the background color of the software view, the moving speed and zoom
speed of the mouse in the view, as well as the switch of model lighting.
Steps

 Set the view background: Click the color to be set, the background color is black by

default.
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 FOV(Field of View): Drag the moving bar, or directly input the value of 15-85, you can

adjust the size of the field of view in the perspective projection.

 Moving speed: drag the moving bar, or directly enter a value from 1 to 40, and click OK

to save the setting. The faster you move, the more you move the point cloud across the

view.

 Scale speed: drag the moving bar, or directly enter a value from 1 to 40, and click OK to

save the settings. The higher the zoom speed, the faster the point cloud is zoomed on

the view.

3.1.8.3. Model Settings
Description
Display the azimuth and altitude angle.
Steps

 Model display lighting settings: Drag the moving bars of azimuth and elevation angles or

directly adjust the angle to change the angle at which the model displays lighting.

 Check "Open Lighting Effect Options" to open the lighting settings.
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3.1.8.4. Others

3.1.8.4.1. Units Setting

Units include Meter, International Feet and US Survey Feet.

3.1.8.4.2. Import Point Cloud

Description
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When dragging the las point cloud to the view or opening the las point cloud, it controls
whether to convert the las to codata format. When this option is checked, the external
storage point cloud conversion will be performed; when it is not checked, the las format will
be loaded directly.
Steps

 Check File and Project -> System Settings -> Point Cloud Import Settings -> Drag and

drop to import whether to convert codata, and point cloud is determined.

3.1.8.4.3. GPU acceleration

Description
The GPU acceleration function is enabled by default. This function requires that the
computer hardware has a discrete graphics card to provide GPU support.

3.1.8.4.4.DEM Pixel Center Settings

Description

Sets whether the pixel drawing is based on the center of the pixel in the upper-left corner or
the boundary point in the upper-left corner when generating DEM. The results generated
under these two benchmarks will have a horizontal offset of half a pixel in length.
After setting up, you need to restart the software before it will take effect.

3.1.9. Theme

Click the theme function in the upper right corner of the home interface of the software to
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select different styles of themes, and the software will display the selected theme style as
the default.
The software provides four styles of themes, blue, black, silver and aqua.

3.2.Home

3.2.1. View Direction

View directions include front view and isometric side view. Front view includes front, rear,
left, right, top, and bottom views. Isometric view supports viewing from four directions:
southwest, northwest, northeast, and southeast.

3.2.2. View Scale

3.2.2.1. Full Extent
Description
Scales the data in the view to the original display scale.
Steps

 For the data after executing the zoom-in and zoom-out commands, click Home->View

Scale->Full Extent;

 Point clouds, DEMs, DOMs, models, etc. are scaled according to the view's bounding

box.

3.2.2.2. Zoom in
To zoom in the data in the view, click Home->View Scale->Zoom in or slide the middle mouse
button up to display the zoomed-in data.

3.2.2.3. Zoom out
To zoom out the data in the view, click Home->View Scale->Zoom out or slide the middle
mouse button down to display the zoomed-out data.

3.2.3. View Control

3.2.3.1. Pan
To pan the object in the view, press and hold the middle mouse button to drag.
Execute the lock pan function, the data object will not be panned.

3.2.3.2. Rotation
To rotate the object in the view, press and hold the left mouse button to rotate the object in
the view.
Execute the lock rotation function, the data object will not be rotated.

3.2.3.3. Zoom
To zoom the objects in the view, slide the middle mouse button up to zoom in, and slide the
middle mouse button down to zoom out.



CHCNAV COPROCESS2.6 USER MANUAL P a g e | 145

Execute the lock zoom function, the data object will not be zoomable.
3.2.3.4. Set the center of rotation

Description
Double-click with the left mouse button to set the rotation center of the object.
Steps

 Double-click the point on the object in the view with the left mouse button, you can

view the XYZ coordinate information of the point in the lower left corner, and set the

point as the new rotation center. When the object is rotated, the rotation will take this

point as the center.

3.2.3.5. Linkage
Description
Display multiple views in linkage to realize synchronous zooming and panning of multi-view
data objects.
Steps

 After creating multiple views, click Home->View Control->Linkage to load the window

linkage interface.
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 Load the view that needs to be linked in the window list on the left to the linkage

window on the right, and click OK. The linkage of multiple views can be realized, and

the synchronous zooming and panning of viewing objects can be realized.

Notes
The view linkage is valid for multiple views. When there is a view, the command is grayed out
and cannot be used.

3.2.3.6. Orthographic
The projection method of objects in the view is orthographic projection by default.
Orthographic projection is also called parallel projection. No matter how far the object is
from the camera, the size of the object remains unchanged after projection.
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3.2.3.7. Perspective
Perspective projection uses perspective projection to view objects. The closer to the
viewpoint, the larger the object; the farther away from the viewpoint, the smaller the object.

3.2.4. Scene Roam

3.2.4.1. Viewpoint Roaming
Description
Navigate through the objects in the view by setting the viewpoint. Roaming according to the
current perspective position, manually adding/deleting viewpoints, the camera will roam
according to the order of addition; the current roaming information can be saved and
imported directly next time.
Steps

 Import point cloud, click Scene Roaming to activate Roaming Mode;

 Switch to viewpoint roaming and click "Add viewpoint" to add a viewpoint at the center

of the current screen;

 Switch the viewing angle and click multiple times to add viewpoint;

 Click Start to roam the point cloud view in sequence according to the set viewpoints;

 In addition, viewpoint roaming also supports local txt format viewpoint file import and

roaming speed adjustment.
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3.2.4.2. Trajectory Roaming
Description
Navigate through view objects by setting the mode of the browse track. Roaming according
to the position of the track point: click the left mouse button on the point cloud to add a
viewpoint, or import a track file to add a viewpoint;
Steps

 Import point cloud, click Camera Roam, activate trajectory roaming;

 Switch to track roaming, left-click on the point cloud to create roaming track point;

 Switch the viewing angle and click multiple times on the point cloud;

 After drawing the roaming track, click Start to roam the view according to the drawn

track.

 Likewise, the track view supports the import and export of txt track paths, as well as the

adjustment of roaming speed. In addition, the elevation of the track can be adjusted

during the walk.
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3.2.5. View Management

3.2.5.1. New
Description
Create and open a new view.
Steps

 Click home -> ViewManagement -> New View to create a new view;

 Drag and drop point cloud or model data from the workspace into a new view to load

the data;

Notes
A maximum of four views can exist simultaneously in a new view.

3.2.5.2. View Layout
Description
The window layout is used when there are multiple views. It can be used in tabbed layout,
tiled layout, horizontal layout, and vertical layout.
Steps

 Click Home -> View Management -> New View to create at least two viewWindows.

 2Click home -> View Management -> View Layout and select TAB Layout, Tile layout,

horizontal layout and vertical layout respectively to see the different layouts.

Notes
The window layout function is effective for multiple views. If multiple views exist, the title of
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the currently active view is marked with Focus.
3.2.5.3. Resetting the Layout

Steps

 Click to reset the layout. The system displays Do YOU want to restart the software?

Select OK to restart the software.

 The software interface workspace and output Windows and views are restored to their

initialized state.

3.2.6. Colorization

It supports multiple point cloud colorization: height, intensity, classification, single, blend,
returns, return number, RGB and EDL etc. User can also configure the settings range and
point size.

3.2.6.1. Color by Height
According to the elevation value of the point cloud, it is mapped to the specified color
interval, which is convenient to observe height change.

3.2.6.2. Color by Intensity
Map the intensity values of point cloud to uniformly varying color intervals.
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3.2.6.3. Color by Blend
Point clouds will be colored by intensity & height together under this mode.

3.2.6.4. Color by RGB
Point clouds will be colored by real RGB color under this mode.
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3.2.6.5. Color by Classification
Point clouds will be colored by classification color under this mode.

3.2.6.6. Color by Single
Point clouds will be colored by different colors based on different files under this mode.
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3.2.6.7. Color by Time
According to the different GPS time values of the point cloud, the time attributes are
mapped to uniformly changing color values.

3.2.6.8. Color by Merge
Point clouds will be colored by Height & Classification & Return number, intensity &
Classification & Return number together under this mode.
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3.2.6.9. Color by Return Number
Point clouds will be colored by return number color under this mode.

3.2.6.10.Color by Number of Returns
Point clouds will be colored by number of returns color under this mode.
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3.2.6.11.Size Settings
User can configure point cloud size based on this settings.

3.2.6.12.Color Parameter Settings
User can configure parameters on “Settings”. Click “Reset” to restore default settings.
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3.2.7. Tools

3.2.7.1. Merge
Steps

 Import two or more pieces of point cloud data and activate the point cloud merging

function;

 Select the point cloud files to be merged in the point cloud list, select the output path,

and click OK;

 After the merging process is over, it will prompt whether to add the merged point cloud.

Click OK to load and display the merged point cloud data;

3.2.7.2. Sampling
Description
According to different sampling types, the point cloud data is thinned out.
Steps

 Import point cloud, click Home->Point Cloud Processing->Point Cloud Sampling, as

shown below:
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 Select the point cloud file in the point cloud list, select the random sampling method,

enter the sampling rate, and randomly thin the point cloud according to the sampling

rate; select the minimum point spacing sampling method, and enter the point spacing

to uniformly thin the point cloud according to the sampling interval.

 Select the output path and click OK to thin the point cloud, and output and save the

sampling results at the same time.

 After the sampling is completed, it will prompt whether to add the thinned point cloud.

Click OK to load the data.

Settings
Sampling Rate (%): The thinning rate of random sampling, the default is 50%, and the value
range is 0~100%. The reserved points are the product of the total points and the sampling
rate. The smaller the sampling rate is, the more points are reserved.
Point Spacing (m): the distance between two points when sampling, the default is 0.05m,
the smaller the sampling interval, the slower the thinning speed, and the more points are
retained; the larger the sampling interval, the faster the thinning speed, and the points
reserved few.

3.2.7.3. Class Convert
Description
Convert point clouds of one class into another class in batches.
Steps
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 Select the point clouds in las format that you want to convert and click the class

conversion function.

 Select the classes of the source and target point clouds.

 Click icorn to do the class conversion.

 Click icorn to switch the source and target point clouds.

3.2.8. Clipping

3.2.8.1. Clip Mode
Controls the on and off of point cloud cropping mode.

3.2.8.2. Rectangle Selection
Description
Select the point cloud by a rectangle selection.
Steps

 Click the clip mode button to enter the crop mode; click the function button to activate

the rectangle selection command;

 In the view window, click the left button to select the position of the upper left corner

of the rectangle, hold down and drag the mouse until the position of the lower right

corner of the rectangle is obtained, and after releasing the mouse, the point cloud in

the rectangle area will be highlighted.
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 After the first selection, you can continue to make a rectangle selection. Selecting an

area will add or subtract the selected area according to the state of the subtraction

mode.

3.2.8.3. Polygon Selection
Description
Select point cloud by polygonal means.
Steps

 Click the crop mode button to enter the crop mode; click the function button to activate

the polygon selection command;

 Left-click to select the polygon vertex positions in turn, left-click to double-click the last

vertex to end the polygon selection; the selection area is highlighted (red) as shown

below;

 When the vertex position is wrongly selected, the Ctrl+Z key can cancel the last selected

point, which supports multiple cancellations in succession;

 After the first selection, multiple selections can be made on the basis of the first time.

Selecting an area will add or subtract the selected area according to the state of the

subtraction mode.
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3.2.8.4. Subtract
Description
This function is used in conjunction with rectangle selection and polygon selection to control
whether the currently selected area will be added or subtracted.
Steps

 Subtract mode is automatically activated when a selection command (rectangle

selection, polygon selection) is activated;

 By default, the button is in the unselected state, and when it is selected, it is in the

selected state, and the selected area will be added;

 When this button is selected, it is in the state of subtraction, and the final result of the

selection is to subtract the overlapped part of the current selected area from the

selected area.

3.2.8.5. Out Cut
Description
Crop the point cloud outside the selection range.
Steps

 Activate the selection function to obtain the selection area; perform the outer cropping

function, as shown in the figure is the effect of cropping.

 After one cut, you can continue to select and cut multiple times on the cut result.
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3.2.8.6. In Cut
Description
Crop the point cloud inside the selection range.
Steps

 Activate the selection function to obtain the selection area; Perform the in cut function,

as shown in the figure is the effect of cropping.



CHCNAV COPROCESS2.6 USER MANUAL P a g e | 162

3.2.8.7. Clear Cut
Description
Clears all selection operations and cropping results.
Steps

 Perform selection or cropping operations, highlight selected areas and create cropping

results;

 Execute the Clear command to immediately delete all selections and crop results.

3.2.8.8. Save Result
Description
Save and output the result of point cloud cropping.
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Steps

 Execute the inner trimming or outer trimming command to get the trimming result.

 Activate the save and crop function, pop up the save interface, select the original point

cloud file to be cropped and saved, and select the file save directory. The new clip file is

named by adding -clip after the original point cloud file name.

Parameter Settings:
Save Format: Support to write the clipped point cloud to las or codata format. If you
generate codata, you can import it directly into the view.
Merge Output: If the number of point clouds participating in clipping exceeds 2, check this
option to merge the clipping result into a point cloud file.

3.2.9. Measurement

3.2.9.1. Point
Description
Left-click to select a point on the point cloud to query the coordinates, intensity, time,
category and other information of the point.
Steps

 Click Main->Point Cloud Measurement->Single Point, enter the coordinate

measurement command, and the operation method is prompted at the top of the view;

 Select and click the query point with the left mouse button, the XYZ coordinates, RGB

color, time, intensity and category of the point will be displayed on the point cloud.
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3.2.9.2. Length
Description
The length measurement uses mouse click to query the distance between two points, and
also provides the coordinate difference between the last point and the previous point.
Steps

 Click Main->Point Cloud Measurement->Length Measurement to enter the length

measurement mode;

 The left mouse button selects multiple points on the point cloud in turn, the length of

the polyline is displayed, and ctrl+Z can undo the previous point.
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3.2.9.3. Angle
Description
The angle measurement tool selects three measurement points in turn with the left button,
and the degree of each angle of the triangle can be obtained.
Steps

 Click Home->Point Cloud Measurement->Angle Measurement to enter the angle

measurement mode;

 The left-click selects three points in turn, and the angle measurement information is

displayed in the prompt box.
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3.2.9.4. Area
Description
The area measurement function calculates the projected area within the drawn area by
drawing a polygon.
Steps

 Click Main->Point Cloud Measurement->Area Measurement;

 Select the polygon area with the left mouse button, and display the projected area in

the area in real time. ctrl+Z can undo the previous point.
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3.2.9.5. Density
Description
The point density is obtained by calculating the average number of points in a unit square
meter, which can be used as an important indicator to measure the quality of point cloud
data.
Steps

 Click Main->Point Cloud Measurement->Density Measurement to enter the point

density measurement command.

 By default, the point density in a unit square meter can be calculated and displayed, or

you can enter the length of the square by yourself, and left-click a point to calculate the

point density within the selected range.

 Click the close button in the upper right corner of the point density to end and exit the

point density measurement command.

3.2.9.6. Multi-point
Description
Select and export multiple 3D point coordinates, intensity, classification, RGB and time and
other information, and support to draw two lines to obtain the coordinates of the
intersection.
Steps

 Click point cloud measurement -> multi-point selection to load the multi-point
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measurement panel shown in the figure below;

 Left-click to select and click a point on the point cloud, a 3D sphere and a 2D label will

be drawn at each selected point, and the index, XYZ, intensity, category, time and RGB

information of the selected point will be displayed in the measurement panel.

 After selecting the point, click the Export, enter the name of the save file, and click Save

to export the data table in csv format.

 Hold down the shift key, and the mouse draws two intersecting lines in turn to fit the

position of the intersection.

Settings
Point size: control the display size of the yellow 3D sphere drawn when selecting a point;
Number of points: Display the number of points in the measurement panel;
Start Index: the default start sequence number value when selecting a point;
Import: Import the multi-point measurement values in csv format, and display the imported
point label index in the view;
Delete: Select a row in the multi-point measurement panel to delete the information of the
point;

3.2.9.7. Height Inspection
Description
Calculates the elevation error for imported control points and point clouds.
Steps

 Enable the Height Inspection, click the Import button to load and display the control

points, right-click to delete the selected points, and position to center the points in the
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view and highlight the name label.

 Click Calculate to display the matched points on the point cloud along with the

elevation error.

 Click Sort to sort according to the field.

 Export report, you can export and save the elevation report in .csv format.

 This tool also supports batch height inspection of point cloud files in the las format.

Click “Point cloud file”, check the “Select point cloud file” option, and click OK. Then

repeat Step2 and Step3, you can obtain the height inspection result of the point cloud

file in the las format and output the neighboring point cloud file in the las format in the

file directory where the control points are.
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Elevation check method:
Several points with lower elevation values and ground points are found as matching points in
a certain neighborhood range of each control point, and the software obtains the nearest
two-dimensional distance and three-dimensional distance of these points.
The software first uses the point closest to 2D for matching, and if the elevation difference
exceeds the built-in threshold, the point closest to 3D distance is used as the matching point
to calculate the elevation difference.
If no ground points are found, select the points with the lowest elevation values in the range.

3.2.9.8. Density Analysis
Description
This function analyzes the density of point cloud data and outputs a html report for density
quality check.

3.2.9.8.1. According to Point Cloud

Steps

 Click Point Cloud Measurement -> Density Quality Inspection, enter the density interval

value and grid size, as shown in the following figure:
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 Select the output path and click OK to start the density analysis calculation. After the

processing is completed, save the quality inspection results and html report in the

folder.
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Settings
Density Threshold: The density of point in different threshold ranges is displayed with
different colors.
Grid Size (m): When the point density statistics are carried out based on the grid size as a
unit, the size of the grid side length in the process of point cloud grid.

3.2.9.8.2. Customize Regional

Operation Procedure:

 Click the density inspection, input density interval value and grid size;

 Click the polygon box and select the area to be inspected on the point cloud.

 Set the saving path and click OK.

 After processing, the selected folder will save the results of the quality check and the

HTML report.
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3.2.9.9. Profile Analysis
Description
By drawing and displaying section lines, the moving and measuring functions of slices can be
realized.
Steps

 Activate the section analysis function, left-click to select a point to draw a section line,

as shown in the figure below, and double-click the left-click at the last point to end the

drawing.

 Loads the profile measurement analysis window, which provides the function of slice

movement and width adjustment. Enter the slice width and click the Update Width

button to display the adjusted slice. Slice movement can be controlled by modifying the

offset value.
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 Activate the profile measurement button, drag the blue triangle with the left mouse

button in the section area until the end position, the upper right side of the window

displays the horizontal, vertical, hypotenuse distance and slope. Slope is the angle

between the horizontal and the hypotenuse.

 By default, the section is displayed in proportion. Activate the button to display the

actual size, as shown in the following figure:

 Section display settings, you can modify point size, control outline effects and grid
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display, adjust section background color and grid color.

 Click the Save button to save the scene in the current profile view to the specified

path.

3.2.9.10.Selection
Description
Box-select the point cloud in the view to realize the linkage between the view point cloud
and the specific point cloud nodes in the resource.
Steps

 Activate the point cloud selection function and select any point cloud in the view;

 The left mouse button selects the upper left and lower right corner points in turn, and

by drawing a frame selection area, you can quickly locate the point cloud list node in

the workspace, and realize the linkage between view selection and point cloud nodes.
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3.2.10.Slice

3.2.10.1.Horizontal Slice
Description
Select a point to create a new horizontal slice.
Steps

 Click Main -> Point Cloud Slice -> Horizontal Slice;

 Left-click to select a point on the point cloud to create a new horizontal slice, hold down

the ctrl key and scroll the mouse wheel to move the slice, and hold down shift to scroll

the mouse wheel to adjust the display thickness of the slice.

3.2.10.2.Vertical Slice
Description
Create vertical slice.
Steps

 Click Main->Point Cloud Slice->Vertical Slice to enter the vertical slice command;

 Select two points with the left mouse button to create a new vertical slice, hold down

the ctrl key and scroll the mouse wheel to move the slice, and hold down the shift key

to scroll the mouse wheel to adjust the display thickness of the slice.
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3.2.10.3.Settings
Set the slice thickness and step size, the step size indicates the stride of moving the slice.
Steps

 After creating a new slice, click Home->View Slices->Slice Settings.

 The horizontal slice and vertical parameters can be set separately. After modifying the

slice parameters, click Close, and the modification will take effect.

Settings
Slice thickness: The default is 0.2m. By modifying the slice thickness, the vertical slice
thickness can be changed. The minimum slice thickness is 0.1m.
Slice step: The default is 0.2m, which controls the sliding speed of the slice. The larger the
value, the faster the scroll wheel slides up and down. The minimum slice step size is set to
0.1m.

3.2.10.4.Show
Description
Toggles between point cloud browsing mode and slice display mode.
Steps

 After creating a new slice, click Home -> Point Cloud Slice -> Show to exit the slice mode,
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and click again to enter the slice mode. The shortcut key is Q.

3.2.11.Windows

3.2.11.1.Resources
Description
The Resources are managed according to BrowseProject and BlockProject. BrowseProject can
load and display point cloud and model data.

Steps

 The workspace is checked by default. Click Home -> Windows and cancel the Resources

check box to hide the Resources. Check to duplicate the Resources

Shortcut keys:
Middle click any node in the Resources to display or hide the project or data.

3.2.11.1.1.Property

Description
View the basic attributes and classification of the point cloud. The basic attributes include
the bounding box size, time, intensity and number of points. The classificationdisplays the
number of point clouds in each category.
Steps

 Right click the point cloud and select “Property” to view the point cloud properties.
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3.2.11.1.2.Show Data/Hide Data

Description
Сan show or hide the point cloud or mesh.

3.2.11.1.3.Centered To Active View

Description
Center the point cloud and model data to the active view
Steps

 When the software opens multiple views, click a view with the left mouse button to

activate it. Right-click the added point cloud or model data, select “Center To Active

View”, it will display the data in the center view.
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3.2.11.1.4.Remove Data From Active View

Description
This function is to delete the data in the current view and retain the data nodes in the
Resources.
Steps

 Right click the data node and select “Remove Data From Active View” to remove data in

the view. Drag data node to the view, the data will be loaded in the view again.

3.2.11.1.5.Export Point Cloud

Description
Export and save multi segment point cloud data.

3.2.11.1.6.Delete

Delet the data from Resources nodes and views.
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3.2.11.2.Output
Display relevant operation information and tips. Click Home -> Windows- > Output to show
or hide the output window.

3.2.11.3.Tool
Show or hide the processing tool.

3.2.11.4.Box
Show or hide the bounding box of point cloud or mesh.

3.2.11.5.Legend
Show or hide the color bar of current render settings.

3.2.11.6.Cross
Show or hide the cross in the center of view.
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3.3. Terrains

3.3.1. Import Las

Description
The import LAS function enables users to use las data to complete the main process of DEM
production.
Steps

 Click terrain Module-> Import LAS, and the dialog box for importing point clouds that

need to produce terrain will pop up after clicking.

 Click the add LAS file button to select the LAS to be imported, and click Open to import

LAS.

 Click the preview button to add to the workspace node tree, and subsequent users can

carry out the main process of DEM production.

Note:
The main process of DEM production can be found in the "4.2Workflow" section of this
document.

Parameter Description
Add LAS file: Import point clouds that require production terrain.
Clear: Clear the imported point cloud.
Preview: Loads the selected point cloud into the workspace node tree.



CHCNAV COPROCESS2.6 USER MANUAL P a g e | 183

3.3.2. Work Flow

Include five functions: Wizard, Block, Filtering, Export Point Cloud and Export DEM.

3.3.2.1. Wizard
Description
Create a wizard to generate results of ground point or DEM.
Steps

 Open “System Parameters Setting” and confirm “Convert to codata when load date to

view” is checked.

 Import *. LAS or *.codata point cloud data need to be processed.
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 Click Terrains -> Wizard, the processing settings dialog will poll up, which includes the

settings of Block, Filtering and Export. Set parameters and click “Next”.

Parameter Description
Advanced Settings: Click Advanced settings and all settable items will be displayed.
Block Settings:
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Length and width: The length and width of a single grid block.
Block Name: The name of the block folder. The default is the current date.
Output Path: Data saving path.
Generate a single block: All imported data is divided into a whole block.
PointCloud Sample: After checking, set the sample interval to dilute the point cloud.

Filtering Settings:

Isolate Point Filter: Points with less than the specified value in a certain neighborhood of
point cloud data are identified as outliers. This function is mainly used to remove outliers in
the air or below the ground. The isolated point deviates far from the main point cloud and
has the characteristics of small number of points and discrete distribution.
Auto Calculate:When checked, the software will automatically calculate the "Search Radius"
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and "Neighborhood Points" of isolate point filter.
Ground point filter: According to the scene settings, the software will automatically adjust
the filtering parameters.
Maximum Building Size: The default value is 80m. Generally, it can be kept as the default, or
it can be set according to the longest hypotenuse of the building.
Maximum Terrain Angle: Select the section with the steepest slope for measurement.
Iteration Angle: The maximum value of the angle from the point to the three vertices of the
triangulation. The larger the iteration angle is, the farther the point is from the triangulation.
During the iteration, the points that are far away and meet the iteration angle will be added
to the ground points. The default value is 25°, which should not be set too large.
Iterate Distance: The vertical distance from the point to the tin plane.
Point Density: The thinning degree of filtering results.
Reduce the iteration angle when edge less than (m): When the edge length of the
filter triangulation network is less than the set value, the number of iterations at this point is
reduced. It can effectively reduce the roughness of ground points.

Stop triangulation when edge less than (m): ground points whose distance is less than

the set threshold will not continue to generate triangle mesh. This can prevent that the

generated ground points are too dense.

Notes
It is recommended to adjust the iteration Angle first. If a large number of feature points are
mistakenly classified as ground points, the iteration Angle is reduced, and vice versa. The
range of each adjustment is recommended to be 3°.

Export Settings:
Merge into single file:When this option is checked, the output results of different blocks will
be merged into one file.
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Generate Key Point:When checked, you can set the percentage of selected feature points to
export ground points.
Auto Calculate: When this option is checked, the software will automatically calculate the
grid distance.
DXF Constrain:When this item is checked, you can select a DXF file for constraints.
Result Type: You can choose DEM and DSM result type output.
Output Format: Output data in .tif format.

 After setting the parameters, click Next. After confirmation, click the "Start" button, and

the software will automatically process the ground points and DEM under the block

project path.

 After processing, click "Finish" button, the software will automatically load block data

for subsequent manual editing operations.

3.3.2.2. Block
Description
Divide point cloud data into blocks according to user-defined length and width.
Steps

 Import LAS data need to be processed.
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 Click Terrains -> Work Flow -> Block, set the length, width, block name and output path.

 Click “OK”, the block data will be generated. After generation, the software will prompt

whether to load the block data.

 Click “OK”, the block data will be added to the software.
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Filtering Settings:
Import DXF Boundary: when checked, the imported standard split grid will be used for
blocking.
Requirements for the boundary files in the dxf format: Version Auto 2000/LT2000, and
rectangular grids should be arranged in an adjacent manner and can not overlap.

Length and width: the length and width of a single grid block.
Chunk name: the name of the chunk folder. The default is the date of the day on which the
chunk was built.
Generate a single block: when checked, the whole point cloud will be divided into the same
piece when the software is divided into blocks.
Sampling Value: the thinning interval can be set to dilute the point cloud.
Point cloud Sampling: after checking, set the thinning interval to dilute the point cloud.
Boundary Extension: when checked, an extended border las file is generated under the path
of each block, which is used to assist ground point classification.
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3.3.2.3. Filtering
Description
Filtering is performed for the currently loaded block data.
Filtering of isolated points, low points, ground points, buildings, or vegetation on all
partitioned files or several files at once.
Steps

 After the block data loaded. Click Terrains -> Work Flow -> Filtering.

 Select the grid to be filtered. Support Ctrl+A for select all and other functions. Click

“Next”.

 Set parameter of isolate point filter and ground point filter. Click “Next”.

 Set filtering parameters. For isolated point filtering, after selecting automatic

calculation, the software will calculate the filtering parameters automatically；When

unselected, you can manually set the search radius and number of neighborhood

points.
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 Select ground filtering, select whether to check building filtering or vegetation filtering,

and click Start to proceed with filtering processing. The processing results will be saved

in the block node.
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As shown in the above figure, the filtered point cloud has_ Classified suffix

Filtering Settings:
Isolate Point Filter: Points with less than the specified value in a certain neighborhood of
point cloud data are identified as outliers. This function is mainly used to remove outliers in
the air or below the ground. The isolated point deviates far from the main point cloud and
has the characteristics of small number of points and discrete distribution.
Auto Calculate:When checked, the software will automatically calculate the "Search Radius"
and "Neighborhood Points" of isolate point filter.
Ground point filter: According to the scene settings, the software will automatically adjust
the filtering parameters.
Maximum Building Size: The default value is 80m. Generally, it can be kept as the default, or



CHCNAV COPROCESS2.6 USER MANUAL P a g e | 193

it can be set according to the longest hypotenuse of the building.
Maximum Terrain Angle: Select the section with the steepest slope for measurement.
Iteration Angle: The maximum value of the angle from the point to the three vertices of the
triangulation. The larger the iteration angle is, the farther the point is from the triangulation.
During the iteration, the points that are far away and meet the iteration angle will be added
to the ground points. The default value is 25°, which should not be set too large.
Iterate Distance: The vertical distance from the point to the tin plane.
Point Density: The thinning degree of filtering results.
Reduce the iteration angle when edge less than (m): When the edge length of the
filter triangulation network is less than the set value, the number of iterations at this point is
reduced. It can effectively reduce the roughness of ground points.

Stop triangulation when edge less than (m): ground points whose distance is less than

the set threshold will not continue to generate triangle mesh. This can prevent that the

generated ground points are too dense.

Building Filtering (Optional)
It is used to classify building points and non-building points. By default, building filtering is
not selected.
Distance from ground:
The height of the lowest point of a building from the ground is mainly to avoid the impact of
plane points close to the ground (such as cars, small rocks, etc.) on the subsequent
extraction results of building contours.
It is recommended to set the range between 1 and 2.5 meters. If the scene is a low rural
house, this value can be set to 1.2; The height of urban buildings is generally above 3m, and
this value can be set to 2.5 to ensure the accuracy of building contour extraction.
Note: Setting this parameter will result in missing points at the bottom edge of the building,
but it has little impact on building contour extraction.
Maximum normal angle:
The angle value between the normals of adjacent points in a single building. The larger the
value, the rougher the extracted building surface. The smaller the value, the smoother the
extracted building surface. The default value is 6, and it is recommended to set the range
from 2 to 6 °. The larger the parameter, the more complete the building. If it is too large,
some building attachment points may also be mistakenly classified as building points. The
specific setting needs to be based on the actual situation of the point cloud, which has a
relatively sparse density, When the thickness is relatively thin, small points can be set, such
as 3. When the thickness is large and the point density is high, it can be set to 6 or above.

Maximum point spacing:
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The maximum distance allowed between adjacent building points controls the integrity of

building extraction. Suggest setting the range to [1,1.5].

Minimum number of individual points:
The number of points occupied by the smallest building in the actual scene, which is the
minimum number of points required to form a single building. Buildings with fewer points
than the set value will be discarded. By setting this parameter, some ground objects that are
mistakenly divided into buildings, such as vehicles with fewer points, shrubs, etc., can be
removed.

Minimum area of individuals:

The number of points occupied by the smallest building in the actual scene, which is the

minimum number of points required to form a single building. Buildings with fewer points

than the set value will be discarded. By setting this parameter, some ground objects that are

mistakenly divided into buildings, such as vehicles with fewer points, shrubs, etc., can be

removed.

Vegetation Filtering (Optional)
Used to classify vegetation points and non-vegetation points. When selecting vegetation
filtering, ground point filtering must be synchronously selected. By default, vegetation
filtering is not selected.
Minimum normal angle:
The angle value between the normals of adjacent vegetation points, with a default value of 6,
is recommended to be set within a range of 6-10 °. The larger the value, the easier it is for
the vegetation layer to be missed, while the smaller the setting, some surface objects may
also be mistakenly classified as vegetation points. In actual settings, if there is a significant
mismatch in vegetation, it is necessary to increase this parameter value appropriately, with
an adjustment range of 1-2 °.
Maximum point spacing:
The maximum distance allowed between adjacent vegetation points. Mainly affects the
integrity of vegetation classification. Setting it too small may result in incomplete extraction
of individual vegetation, while setting it too large may cause adjacent unclassified points to
be mistakenly divided into vegetation. It is recommended to set it within the range of 1-1.5m.
In actual settings, adjustments may need to be made depending on the specific situation.

Source Classification Settings:



CHCNAV COPROCESS2.6 USER MANUAL P a g e | 195

Function description:
The source category refers to the point cloud category that participates in filtering. Only the
selected category will participate in filtering, and the unchecked category will not participate
in filtering processing.

Figure: Source Classification Settings:
This setting can be used to preserve point cloud categories that already exist in the original
data, but the software does not support filtering. But it needs to be manually classify.

3.3.2.4. Export
Description
This function can export point data after classification.
Steps

 Load the block file and click Terrains -> Work Flow -> Export Point Cloud.

 Select the gird to be exported. Click “Next”.
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Notes
If the grid data has been classified, there will be a "[c]" after the grid name.

 Set the category need to be exported (Default is ground). Click “Export”.
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 You will get the point cloud exported in the block folder path.

3.3.2.5. DEM
Description
This function generates DEM in TIF format from point cloud data.
Steps

 Load the block data, Click Terrains -> Work Flow -> Create DEM.

 Select the gird to be exported. Click “Next”.

 Set DEM parameter settings and output settings. Click “Start”.
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Notes
DEM is generated based on classified ground points and DSM is generated based on all
points.

 You will get the DEM/DSM exported in the block folder path.

DXF Constraint:
When DXF constraint is checked, users need to import several range lines in DXF format.
When generating DEM, the software will use the imported scope line to trim the result DEM
according to the user's settings, or at the same time, the points on the scope line participate
in the generation of DEM'.

3.3.2.6. Contour
Description
This function can generate contour data in dxf format based on point cloud data or DEM.
Steps

 Load the block data, Click Terrains -> Work Flow -> Contour.

 Choose to generate contours based on point cloud or DEM.
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 Set contour generation parameters, and select whether to enable contour smoothing

and simplification.(left is the setting interface of generating contours based on point

cloud, right is the setting interface of generating contours based on DEM)

 Click “Start”, after the processing is completed, the contours will be output to the

contour folder under the block project folder.

Parameter setting:
Points type: You can choose ground points or all points. If non-lidar data is used to generate
contours, it is recommended to use all points to generate contours.
Grid Interval: The spacing of the network during the generation of contour lines, which
affects the accuracy of contour lines.
Contour Interval: The height difference of contour lines during the generation of contour
lines, which affects the density of contour lines.
Minimum/maximum Elevation: The elevation range in which contour lines are
generated. The software automatically obtains the minimum and maximum elevations of the
point cloud in the selected scene.
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Length Filter: After generating contour lines, lines whose length is less than the set length
are automatically deleted from the results.
Simplify: If the distance between the current point and the two points around it in a straight
line is less than the set value, the current point will be deleted, can reduce the number of
points without changing their shape.
Contour smooth: The software provides three contour smoothing methods: sliding mean,
spline fitting and tension spline fitting. Generally, sliding means can be used for data.
Neighbor points: The number of points around which each point is smoothed. The
parameter must be odd.
Moving Average: The position of the point to be measured is obtained based on the
weighted fitting of adjacent points, which is suitable for smoothing contour lines generated
by high-density point cloud data.
Spline Fitting: By constructing piecewise polynomial fitting data, combined with
second-order differentiability, local smoothing processing is realized, which is suitable for
smoothing low-density contour data.
Tension spline Fitting: Curve interpolation is carried out through adjacent points, and vertex
correction is achieved by using a certain proportion coefficient, which is suitable for
smoothing low-density contour data.

3.3.2.7. Elevation Point
Description
Based on the point cloud data, this function can generate the elevation points in DAT format
according to the square grid or diamond grid.
Steps

 Load the block data, Click Terrains -> Work Flow -> Elevation Point.

 Select the gird to be exported.

 Click Next to set elevation point generation parameters;

 After confirming the parameters, click Start;

 After the processing progress is completed, the elevation point data will be output

successfully.
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Parameter setting:
Points Type: You can choose ground points or all points. If non-lidar data is used to generate
contours, it is recommended to use all points to generate contours.
Elevation Point Style: Square or diamond can be selected, and the resulting elevation points
will be arranged according to the set shape.
Grid Interval: The side length of the grid used to fit the elevation when generating elevation
points.
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3.3.3. Block Management

3.3.3.1. Load
Description
Load and display block data.
Steps

 Click Terrains -> Block Management -> Load, select block data, and click open to load

and display block data.

3.3.3.2. Select
Description
Load and display the point cloud data in the block grid.
Steps

 After loading the block data, click Terrains -> Block Management -> Select. Draw a

rectangular box to select the grid, and then the point cloud data corresponding to the

grid will be loaded.

 Right click on a grid in the resources node tree, and then click "Load grid data" in the

right menu can also display the point cloud data in the block grid.
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3.3.3.3. Save
Description
Manually save the data such as point cloud, TIN, contour line and elevation point in the
current display block grid.
Steps

 After the block project is loaded, click the block Save function in Block Management to

manually write the current edit result to the local block project.

3.3.3.4. Save Contour
Description
Manually save the currently displayed contour data.
Steps

 After the block project is loaded, click the block Save function in Block Management to

manually write the current edit result to the local block project.

3.3.4. Category Editing

3.3.4.1. Fast Filter
Description
Filtering processing is carried out for the point cloud in the selected area.
Steps

 Select the area of the polygon with the left mouse button on the active view and

right-click to end the selection. After box selecting all the filter areas, right click to carry

out the filtering processing.

 Click "Filter" to filter the selected polygon region, and the shortcut key is Space.
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(1) ”Undo” can undo the previous filtering result, and the shortcut key is Ctrl + Z.

(2) “Redo” can restore the filtering result before the last undo operation, and the

shortcut key is Ctrl + Y.

(3) “Back To Last Point” can cancel the last points drawn, and the shortcut key is U.

(4) "Cancel" can cancel all the points being drawn, and the shortcut key is R.

(5) “Exit”: Exit the fast filter command, and the shortcut key is Esc.

The “Fast Filter” function also supports the boundary expansion.

3.3.4.2. TIN

3.3.4.2.1. TIN

Description
The TIN function is only for ground points in the point cloud that are currently displayed. Can
realize TIN browsing and point cloud and TIN synchronous editing.
Steps

 Load block data and select blocks to be constructed for TIN;
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 Click Terrains ->Category Editing -> TIN, the TIN will be constructed from the displayed

grid data. And TIN data will be automatically loaded to the corresponding block node.

3.3.4.2.2. Profile Editing and TIN refresh

Description
When ground points are edited in the profile editing, the TIN in the main view will update
synchronously.
Steps

 Load block data with ground points, and construct TIN.

 Open the profile editing. Select the area you want to edit. Edit ground points in the

Profile editing window, TIN will update synchronously.
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As shown in the figure above, we painted the misdivided ground points in the profile editing
window on the right as undefined points, and the TIN on the left was also modified
simultaneously.

3.3.4.3. Main-View Classify
Description
If it is obvious that some vegetation and noise points are not correctly classified, you can use
the main view editing function to directly batch classify without drawing the section.
Steps：

 Click Main-View Classify, and the dialog box will appear.
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 Set the source class and target class. You can set more than ten different categories. In

addition, the source category can select multiple tags;

 Click the Rectangle Tool, Polygon Tool or Brush Tool to mark the areas that need to be

reclassified on the main view;

 After drawing, the category of points belonging to the source class in the region will be

modified into the target category.

3.3.4.3.1. Source Category Multiple Selection Mode

Click the button next to the source category to switch to the source category

multiple selection mode. This editing mode enables multiple types of source category
selection.
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3.3.4.3.2. Editing Tool

The editing tool has four types: Rectangle, Polygon classification- Screen Select, Polygon

classification- Model Select and Brush. The operation methods are as follows.

(1) Rectangle

After the “Rectangle” tool is activated, long press and drag on the main view to draw a

rectangular box, release the left mouse button, then the attribute category of the points in

the drawn rectangle area will be changed.

(2)Polygon classification- Screen Select

Left click multiple points in turn in the main view to draw a closed polygon, double click the

left button on the last point to end the drawing, and then you can modify the category

information of the points inside the polygon;

The size and location of the polygon based on the “Screen Select” method are fixed on the

screen and do not vary as the model zooms in, zooms out and moves.

(3) Polygon classification- Model Select

Left click multiple points in turn on the point cloud to draw a closed polygon, double click the

left button on the last point to end the drawing, and then you can modify the category

information of the points inside the polygon;

The polygon drawn based on the “Model Select” method varies as the model zooms in,

zooms out and moves.

(4) Brush
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After the “Brush” tool is activated, long press and drag on the main view to draw an area,

release the left mouse button, then the attribute category of the points in the drawn area

will be changed.

Besides, before using the “Brush” tool, you can adjust the brush size with Ctrl+Wheel.

3.3.4.3.3. Undo/Redo

By clicking “Undo” and “Redo”, you can undo the last edit, or roll back the undo operation.

And the “Undo” operation and “Redo” operation can be carried out for a maximum of 10

times.

3.3.4.4. Profile Editing

3.3.4.4.1. Profile select

Description
Draw the section in the main view by selecting points, and display the section in the section
editing view.
Steps

 Click Terrains -> Profile Editing to open the profile editing view.

 On the main view, left-click two points to determine the position of the section.

 The point cloud of section will display in the profile editing view.

3.3.4.4.2. View linkage

Activate the view linkage icon . When you move or scale the profile editing view, the main
view moves with it.
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3.3.4.4.3. Lock rotation

Activate the lock rotation icon . The point cloud of the profile editing view cannot be
rotated.

3.3.4.4.4. Polygon classify

Description
Draw a polygon in the profile editing view to classify the original category to target category.
Steps

 After loading the profile data, active polygon classify icon , and then set the original

category and target category in the toolbar above the profile editing view.

 Draw polygon area in the profile editing view, left-click and select points to draw

polygon. Double left click to finish drawing. The points of original categeory will be

classified to target categeory.
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3.3.4.4.5. Line above/below classify (shortkey:W/S)

Description
Draw a polyline and classify the original categeory above/below the polyline to the target
categeory.
Steps

 After loading the profile data, active line above/below classify icon / , and then set

the original category and target category in the toolbar above the profile editing view.

 Draw a polyline in the profile editing view, left-click and select points to draw polyline.

Double left click to finish drawing. The points of original categeory above/below the

polyline will be classified to target categeory.

3.3.4.4.6. Frame selection classify

Description
Draw a rectangle according to the center line to classify the original class into the target
class.
Steps

 After loading the profile data, active frame selection classify icon , and then set the

original category and target category in the toolbar above the profile editing view.

 Left click at least two points respectively to determine the center line of the rectangle,

move the mouse to determine the width of the rectangle, double-click the end

3.3.4.4.7. Brush classify (shortkey:X)

Description
Drag and drop in the Profile Edit view to classify the original category in the area into the
target category.
Steps

 After creating a new profile, Click the Brush Categorization , set the source category

and target category in the toolbar above the Profile Edit view.

 drag and drop in Profile Edit view to draw an area, and set the selected area category to
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the target category.

3.3.4.4.8. Front View

Description

Resets the perspective of the section view to front view.

3.3.4.4.9. Profile up

Description

This feature allows you to move up a section area of the same size over a section area that
has been drawn.
Shortcut key:
Press ↑ on the keyboard to quickly move up the profile.

3.3.4.4.10.Profile down

Description

This feature allows you to move down a section area of the same size over a section area
that has been drawn.
Shortcut key:
Press the keyboard ↓, can quickly move down the profile.

3.3.4.4.11.Profile settings

Description
Set the rotation angle and expansion width of the drawn profile, and the interaction mode of
the area above/below the line.
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Profile settings
Steps

 Click the profile settings icon , set the profile parameters.

Parameter Description
Slice width: when checked, the slice width is fixed at the set value. If not selected, the width
can be manually adjusted when drawing the profile.
Global Slice: when checked, the entire point cloud will be profiled.
Fixed view when switching:When this setting is checked, the view will no longer scale to the
entire section after switching the profile.
Above/Below Line - Straight Line Mode: After checking this option, activate the
“Above/Below the line” tool, left click two points to draw a straight line to determine the
area above the line and the area below the line, and then modify the categories of the point
clouds in the area above/below the straight line; If this option is not checked, activate the
“Above/Below the line” tool, left click at least two points respectively to determine the area
above the line and the area below the line, double-click the end the operation, and then
modify the categories of the point clouds in the area above/below the line.
Above/Below Line - Only Edit Data Within the Viewport: After checking this option, activate
the “Above/Below the line” tool to modify only the categories of the point clouds in the area
above/below the line that have been drawn in the viewport; If this option is not checked,
activate the “Above/Below the line” tool to modify the categories of all point clouds in the
area above/below the line that have been drawn.

3.3.4.4.12.Switchover

Description

Toggle source category and target category.

3.3.4.4.13.Undo/Redo

Description

Click Undo and Redo to undo the last edit or to roll back the undo action. Undo and redo
supports a maximum of 10 times.

3.3.5. Building Extraction

3.3.5.1.Outline Extraction

3.3.5.1.1. Single Mode

Single building mode
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description:
Extract individual building outlines for the selected area.
Steps:
1. Click on Outline Extraction, activate the processing tool, and select "Single Building
Mode".
2. Left click on the active view to draw a polygonal area, select all the building areas to be
extracted, and then right-click to extract.
3. Click "Extract" to extract the building outline of the selected polygon area.
During the process of drawing a polygon, right-click and select 'undo' to cancel the previous
point drawn, select 'cancel' to cancel all currently drawn points, and double-click to end the
drawing.

Figure: Single building mode

3.3.5.1.2. Multi building mode

Function description:
Extract multiple building outlines for the selected area.
Steps:
1. Click on Quick Building Extraction, activate the processing tool, select "Multi Building
Mode", and set building extraction parameters as needed;
Left click on the active view to draw a polygonal area, select all filtering areas in the box, and
then right-click to process.
3. Click "Extract" to extract the building outline of the selected polygon area.
During the process of drawing a polygon, right-click and select 'undo' to cancel the previous
point drawn, select 'cancel' to cancel all currently drawn points, and double-click to end the
drawing.
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Figure: Multi building mode
Parameter settings:

Maximum point spacing: The maximum distance between adjacent points of a single

building affects the accuracy of extracting building outlines.

Minimum number of individual points: The number of point clouds for a single building and

building contours with points less than this threshold are not extracted.

Minimum area of individual: The minimum projected area of a single building, and building

contours below this threshold are not extracted.

3.3.5.2. Manual Drawing
Function description:

Draw the buildings outline manually. This function supports three interactive mode including
right angle, by edge and polygon, and the short key is N.
Right angle: The short key is Z;
By edge: The shortcut key is T;
Polygon: The shortcut key is C;
Take a step back: Back to the previous point, and the shortcut key is U;
Cancel: Cancel this drawing process, and the shortcut key is R;
Exit: Exit the manual drawing command, and the shortcut key is Esc.
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3.3.5.2.1. Right angle drawing

Steps:
1. Click “Manual Drawing”, right click "Switch Interaction" and choose “Right angle”;
2. In the main view, use the left mouse to click two points to determine the direction
of the first edge, then click on the other edges in turn;
3. Press Enter or double click, or right click to finish the drawing, and the buildings
outline will automatically close.

3.3.5.2.2. Line drawing

Steps:
1. Click “Manual Drawing”, right click "Switch Interaction" and choose “By edge”;
2. In the main view, use the left mouse to click two points to determine the direction
of the first edge, then click two points on the other edges in turn;
3. Press Enter or double click, or right click to finish the drawing, and the buildings
outline will automatically close.

3.3.5.2.3. Polygon drawing

Steps:
1. Click “Manual Drawing”, right click "Switch Interaction" and choose “Polygon”;
2. In the main view, click multiple points to draw a polygon;
3. Press Enter or double click, or right click to finish the drawing, and the buildings
outline will automatically close.

3.3.5.3. Fast Editing

3.3.5.3.1. Interaction mode

Two interaction modes: rectangular and polygonal.

Rectangle: After selecting the rectangular interaction mode, left click two points on the main
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view to determine an edge of the rectangle. Move the mouse and click the left mouse button
to draw a rectangular box. Release the left mouse button to correct the building outline. The
shortcut key is shift + 1.

Polygons: After selecting the polygon interaction mode, left click on multiple points in the
main view to draw a polygon. Double click on the left mouse button to end the drawing and
correct the building outline. The shortcut key is shift + 2.

3.3.5.3.2. Editing mode

3.3.5.3.2.1. Facade Correction

Function description: Box select the outlines and building elevation point clouds that do not
coincide with the building elevation, and automatically correct the outlines to the position
that coincides with the elevation. The shortcut key is ctrl + 2.
Steps:

1. Click on Building Edit to activate the processing tool dialog box.
2. Select the rectangular interaction mode in the right window processing tool.
3. Select the "Facade Correction" function in editing mode.
4. Draw the rectangle that will be included in the modified area in the main view.

After drawing, correct the outline to coincide with the elevation.

3.3.5.3.2.2. Straightening

Function description:
Box select a jagged building outline and building point cloud to straighten the outline. The
shortcut key is ctrl + 1.
Steps:

1. Click on Building Edit to activate the processing tool dialog box.
2. Select the polygon interaction mode in the right window processing tool.
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3. Select the "Straightening" function in editing mode.
4. Draw the polygons included in the modified area in the main view,

double-click the left mouse button to end the drawing, and the building outline is
straightened as shown in the figure.

3.3.5.3.2.3. Extend Object Extraction

Function description: Select the building outline and the rectangular attachment point cloud
extending below the eaves, and automatically correct the outline to a vector line containing
the rectangular extension object. The shortcut key is ctrl + 3.
Steps:

1. Click on Building Edit to activate the processing tool dialog box.
2. Select the rectangular interaction mode in the right window processing tool.
3. Select the "Extend Object Extraction" function in editing mode.
4. Draw the rectangle included in the modified area in the main view. After
drawing, the outline is automatically corrected to a vector line containing the
rectangular extension object.
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3.3.5.3.2.4. Arc Edge Extraction

Function description: Box select the building outline and arc building point cloud, and
automatically correct the outline to the position that fits with the arc building point cloud.
The shortcut key is ctrl + 4.
Steps:

1. Click on Building Edit to activate the processing tool dialog box.
2. Select the rectangular interaction mode in the right window processing tool.
3. Select the "Arc Edge Extraction" function in the editing mode.
4. Draw the rectangle included in the modified area in the main view, and when
the drawing is completed, the outline will automatically be corrected to the
position that fits with the arc building point cloud.

3.3.5.3.2.5. Rectangular Processing

Function description:
Make rough edge of buildings vertical. The shortcut key is ctrl +5.
Steps:

1. Click on Building Edit to activate the processing tool dialog box
2. Select the “Rectangular Interaction” mode in the right window processing tool
3. Select the " Rectangular Processing " function in the editing mode.
4. Draw the rectangle in modified area in the main view. After drawing, the
outline angle will be automatically corrected to a vertical.
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3.3.5.3.2.6. Cutting

Function description:
Draw a multi-segment line across the buildings outline, cut the buildings outline into

two closed buildings outlines according to the multi-segment line and the cutting width. The
shortcut key is ctrl+6.
Steps:

1. Click on Building Edit to activate the processing tool dialog box;
2. Select the "Cut" function in the editing mode;
3. Set a value for the cutting width parameter, and the default value is 0m;
4. Left mouse button click multiple points, draw a multi-segment line across the

buildings, and double click to finish the drawing process, then the buildings outline is cut into
two closed buildings outlines.
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3.3.6. Contour Edit

Use various tools to edit the automatically generated contour lines. After editing, click Save
Block to write the changes to the local file.

3.3.6.1. Revise
Description
Manually click several points to modify a section of a contour line and change its shape. The
shortcut key is K.

Steps



CHCNAV COPROCESS2.6 USER MANUAL P a g e | 222

 Click the button or press the shortcut key K to activate the repair function;

 Click on a point on the contour you want to edit, then click on multiple points in

succession according to the actual terrain until the color of the point turns green;

 After all the drawing is completed, the single mouse right click and select "Finish";

 Once this is done, a portion of the original contour line will be replaced with a manually

drawn shape.

In addition, the contour repair function can connect two different contour lines, but only for
the same elevation of the line.

3.3.6.2. Connect
Description
Manually click to select two contours to merge the two lines into one. The shortcut key is L.

Steps

 Click the button or press the shortcut key L to activate the connection function;

 Click the left mouse button on the first contour line to be connected, and the contour

line will become highlighted;

 Click the left mouse button on another contour line with the same elevation;

 When this is done, the two contours will be combined into one.
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Notes
Contour merging is only effective for contours with the same elevation

3.3.6.3. Break
Description
Manually click a point or two points on the contour line to form a line segment, breaking one
contour line into two. Single break shortcut key: 1, two break shortcut key: 2

Steps

 Click the button or press the shortcut key 1 or 2 to activate the interrupt function. By

default, the two-point interrupt mode is activated;

 In the case of single point interruption, press shortcut key 1, and then click the left

button on the contour line to break one line into two;

 When two points break, press the shortcut key 2, click the left button on the contour

line, and then click the left button again on the same contour line

 When the operation is complete, one contour line will be broken into two.

3.3.6.4. Add Point
Description
Add A node to the contour line, shortcut is A.
Steps

 Click the button or press the shortcut key A to activate the dot function;

 Click the left button on the contour line to add a node to the selected location.
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You are advised to enable the dot symbol function when using the dot function.
3.3.6.5. Delete Point

Description
Delete a node on the contour line, shortcut is D.
Steps

 Click the button or press the shortcut key D to activate the deletion point function;

 To delete a node in the selected location, click the left button on a node in the contour

line.

You are advised to enable the dot symbol function when using the dot deletion function.
3.3.6.6. Move Point

Description
Move a node on the contour line, shortcut is M.
Steps

 Click the button or press the shortcut key M to activate the shift function;

 Long press the left mouse button on the contour line, drag the point to the target

position, and release the left mouse button to move the node.

If there is no node on the vector line of the mouse capture position, then a new node

will be added to the mouse capture position.

Move point

3.3.6.7. Delete Line
Description
To delete a contour line, shortcut is E.
Steps
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 Click the button or press the shortcut key E to activate the line deletion function;

 Click two points on the view to draw a rectangular box. If drawn from left to right,

contours where the entire line is within the area are deleted; If drawn from right to left,

this contour will be deleted if it is part of the right contour within the region.

3.3.6.8. Undo
Description
Undo the last edit to the contour.
Steps

 Click the button or use Ctrl+Z to undo the contour editing.

3.3.6.9. Redo
Description
Rollback of the last contour undo operation.
Steps

 Click the button or use Ctrl+Y to undo the contour back and forth.

3.3.6.10.Dot Symbol
Description
With the dot symbol display enabled, the nodes of the contour line will be displayed in the
view. The first and last points are shown in red and the middle nodes are shown in purple.

3.3.6.11.Text Symbol
Description
After text symbol display is enabled, elevation information about elevation points is
displayed in the view.
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3.3.7. Text Annoation

Description
Batch generation and deletion of elevation notes on contour lines, elevation notes will be
saved with contour dxf.

3.3.7.1. Generate Annoation
Description
Generate an elevation note at the middle of each contour line in the scene.
Steps

 After the contour is generated, click the Generate Note button;
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 In the pop-up dialog box, check the type of contour line to generate notes, including the

first curve and the count curve;

 Click OK to generate contour notes.

3.3.7.2. Manual Annotation
Description
Manually draw a line in the view and then generate a note at the intersection of the drawn
line and the contour line.
Steps

 After the contour is generated, click the manual note button;

 Click two points on the view to draw a line segment that intersects the contour line;

 After the second point is drawn, contour notes are extracted from all the intersections.
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Notes
If there is no elevation difference between the contour line intersected with the drawn line,
the extraction direction may be wrong.
If the drawn line and the contour line have only one intersection, the note will be generated
in the direction of the drawn line.

3.3.7.3. Delete Annotation
Description
Click on two points to draw a rectangular box with all the notes inside removed.
Steps

 After the contour line and text annotation are generated, click Delete annotation

button;

 Click two points on the view to draw a rectangular box;

 After the second point is drawn, all the notes in the rectangle will be deleted.

3.3.7.4. Clear Annotation
Description
Delete all comments from the view in batches.
Steps

 After generating the contour line and text note, click the Clear note button;

 All text annotations in the view are deleted.
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3.3.8. DEM

3.3.8.1. Load DEM
Description
The DEM linkage view supports loading and browsing DEM data with a large amount of data.
Select a rectangle area in the DEM linkage view to display it synchronously in the 3D view.
Edit DEM in 3D view, the editing results will be saved to DEM files in real time.
Steps

 Click DEM -> Load DEM, open the DEM linkage view.

 Click “Add” to load DEM data.

 Click “Rectangle Selection” to draw the rectangle in the DEM linkage view, and the

corresponding DEM data will be loaded into the 3D view.
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3.3.8.2. Edit DEM
Steps

 Click Terrains ->DEM -> Edit DEM, the processing tool will be displayed.

 Load DEM data into 3D view through DEM linkage view.



CHCNAV COPROCESS2.6 USER MANUAL P a g e | 231

 Click “Model Select” / “Screen Select”, draw the area needed to be edited in 3D view.

 Select a processing mode for edit, include Adaptive Smoothing, Elevation Leveling,

Elevation Smoothing, Fix Invalid Value, Elevation Delete, Remove Spikes.

3.3.8.2.1. Model Select

Description
Select based on model data. The model perspective can be adjusted at will. As the model
view is scaled, the selected area of the model is scaled synchronously.
Steps

 Click to activate the Import scope Lines. This feature supports the import of dxf

vectors as selection areas. Click the import scope line icon, select the dxf data, and click

Open to import the selected dxf data into the view.

 Click to activate the Model Select. After activation, left-click to draw polygon on
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DEMmodel, right-click and choose "Finished" button to finish drawing.

3.3.8.2.2. Screen Select

Description
Select based on screen. It can only be selected in 2D view. The size of the polygon selected
on the screen is fixed and does not change as the model is scaled.

3.3.8.2.3. Adaptive Smoothing

Description
Adaptive smoothing will delete the points inside the drawn polygon, and construct a
triangulation network with the points on the polygon as the feature points, and reconstruct
the elevation points according to the triangulation network.

Parameter settings:
Elevation lift: The smoothing result will add the elevation lift.
Interpolate: If checked, some feature points will be interpolated at the edge of the polygon
to participate in the construction of the network. If not checked, only the vertices of the
polygon will participate in the construction of the network.
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3.3.8.2.4. Elevation Leveling

Description
Change the elevation of the slected area to the set value.

Parameter settings:
Elevation: The elevation of the slected area will be changed to this value.
Default Value: Calculate the average elevation of the selected area.

3.3.8.2.5. Elevation Smoothing

Description
Smooth the elevation of the selected area by using mean smoothing or median smoothing.
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3.3.8.2.6. Fix Invalid Value

Description
Fix invalid value of selected area.

3.3.8.2.7. Elevation Delete

Description
Delete elevation of selected area.
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3.3.8.2.8. Remove Spikes

Description
Remove spikes caused by noise points.

Parameter settings:
Elevation standard deviation: Calculate the standard deviation of elevation value in the
range of point and neighborhood. If the value is greater than the threshold, the point is
judged as a noise point.
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3.3.8.3. Check DEM
Description
Import DEM and control points, calculate the elevation accuracy of DEM.
Steps

 Click DEM -> Check DEM.

 Add DEM data and import check points.

 Click “Calculate”, the software will automatically calculate the elevation error of DEM.

 Click “Export” to export inspection result in csv file.

3.3.8.4. DEMMerge
Description
This feature merges two dems into a new DEM.
If the two DEM resolutions are different, the software will sample the DEM with low
resolution and then fuse the two DEM.
If two dems overlap, DEM 2 data will be used for the overlap area. That is, DEM 2 will cover
DEM 1 to achieve the effect of partial DEM update.
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Steps

 Click terrain Module-> DEM Fusion, and the DEM Fusion dialog box will pop up after

clicking.

 Add original and updated DEM files to be merged.

 After clicking execute, perform the DEM fusion operation, and you can view the fusion

result through the output path.

3.3.8.5. Point Cloud Segmentation
Description
This feature supports the import of .dxf vectors as split regions to split point clouds.

Steps

 Click terrain Module-> Point Cloud Segmentation, and the Point Cloud Segmentation

dialog box will pop up after clicking.
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 Select the las file and the DXF file to set the output path.

 Click execute to split the point cloud, and you can view the segmentation result through

the output path.

3.3.8.6. Rendering Settings
Description
Set DEM and TIN render separately in the main view.
Steps

 Click Terrains -> Other -> Render Settings, click the render Settings dialog box will pop

up;

 Select ribbon and elevation range for triangulation rendering

 Click OK.

3.4. Roads

3.4.1. Project Manager

3.4.1.1. New Project
Description
Create a new Road project.
Steps

 Click Road Module-> Project Manager-> New Project to open the New Project dialog
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box;

 Select a path for saving the project and enter the project name;

 Click OK to create the new project.

3.4.1.2. Open Project
Description
Open an existing road project.
Steps

 Click Road Module-> Project Manager-> Open Project to open the Open Project dialog

box;

 Select the RoadPrj file and click Open to load the road project.

3.4.1.3. Save Project
Description
After creating or opening a project, click Save Project to save the operations that have been
done.

3.4.2. Road Parse

3.4.2.1. Broken Chain
Description
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Broken chain refers to the phenomenon that pile numbers are not connected due to partial
line change or sectional measurement.
If the broken chain information is recorded in the flat curve, it will be automatically imported
when the flat curve data is imported, otherwise it needs to be imported manually.
Steps

 Click Road Module-> Road Parse-> Broken Chain to open the Broken Chain dialog box;

 Click Load Data and select Broken Chain data to import. CSV and TXT formats are

supported;

 The broken chain data is shown in the figure below.

Notes
The pile numbers before and after broken chain can be manually modified. The length and
type are calculated automatically and do not need to be modified.

3.4.2.2. Horizontal Curve
Description
Import horizontal curve data from intersection method or atomistic approach to generate
route and pile-by-pile data.

3.4.2.2.1. Load Horizontal Curve

Description
There are two types of imported flat curves: intersection method and atomistic approach.
Including CSV, JD, XLSX, XLS, PM, ROD and other formats.
Steps
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 Click Road Module-> Road Parse-> Horizontal Curve;

 Select the intersection method or atomistic approach page and click Load Data.

 After the import is completed, you can see the corresponding data in the table.

3.4.2.2.2. Calculate Routes

Description
Route calculation can be carried out after route data is imported.
Steps

 Calculate routes;

Intersection method
The intersection method can detect the virtual intersection before calculating the route.

After the virtual intersection processing is completed, click Route Calculation to calculate the
route information.
Notes
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If the route used by the intersection method does not start from the starting point, the pile
number of the second intersection point of the current route needs to be manually entered
in the second line of the starting pile number.
In addition, since the road data before the first straight and slow point cannot be confirmed
in the above incomplete curve, it is normal for the pile number and design of pile points on
the calculated route to have the following deviation:

1) The route in front of the first ZH point is a short straight line, which does not match the

designed curve;

2) The mileage calculation of the first pile point and the design mileage have a offset of the

size of the cut curve difference.

Atomistic approach
Import the data and click Route Calculate.

 After calculating the route, the route page is automatically redirected;

 Click Route Generate to draw the parsed route directly into the view and mount it

under the route node of the road project;

 Click Route Export to export the route in the format of DXF.
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3.4.2.2.3. By Pile

Description
After route calculation, pile-by-pile operation can be carried out. It includes importing pile
number, generating pile number, pile calculating, pile adding and pile exporting.
Steps

 There are two ways to get pile numbers: load and create;

Pile load:
Click Pile Load in the page of By Pile, select TXT or CSV file, and click Open.
Pile create:
Click Pile Create in the page of By Pile, after setting the parameters, click OK.
Pile Spacing: Distance between added piles.
Keep Main Store: Whether to retain the original primary point after calculation.
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The number information can be seen after the completion of pile-by-pile acquisition.

1. Pile calculation;

After obtaining the pile number, click Pile Calculation to automatically calculate the
pile-by-pile information.

2. Pile add;

Click Pile add and input the pile number to add the corresponding pile.
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3. Pile export.

Click Pile Export to draw the current pile-by-pile data into the view and mount it under the
by pile node of road project.

3.4.2.2.4. Curve Coordinate Calculation

Description
Calculate the pile information through the input point coordinates
Steps

 Click the import button on the Inverse calculation page to import the coordinate file

(CSV, TXT), and click Calculate to calculate the pile information of each point.

3.4.2.3. Markline Transfer
Description
In case of no route file, it can be converted to by pile according to the drawn line. Support
loading vector lines from vector nodes or from local files.
Steps

 Click the road module -> Route Parse ->Markline Transfer, select "By Vector File";

 Select DXF vector path;

 Select the generation mode, including the whole parts or divided equally, whether to

retain nodes;

 Set the starting distance and pile-by-pile interval, click Execute.

When selecting a vector, if you want to load it from a node, you need to select the labeled
node you want to import in your workspace.
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Click Execute to generate and display pile-by-pile, as shown below.

Equal division of the whole section: when inserting the pile point, the bending of the vector
line is not considered, and the pile point is inserted according to the set distance from the
starting point.
Segment and equal division: when inserting pile points, each broken line is taken as the unit,
and inserting pile points are respectively inserted according to the set distance.
Whether to preserve nodes:Whether the nodes of the original vector line are also output as
pile points.
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3.4.2.4. Manual Piling

3.4.2.4.1. Pile Add

Description
Add pile-by-pile points according to point cloud view and support loading to current
pile-by-pile.
Steps

 Import route point cloud and 2D pile-by-pile file;

 Use "Profile Section -> Route Piles " function to generate 3D pile-by-pile(optional);

 Activate the view piling function, click the left mouse button near the piling line to add

piles;

 The plane coordinates of pile points are inversely calculated to pile-by-pile, and the

elevation values are consistent with the selected points;

 After piling is finished, click Export to save piling information to the newly generated

pile-by-pile.

As shown in the figure, the green points are manual piling points, and the red points are 3D
piling points. At the same time, you can delete a row of values by right-clicking in the view
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piling table.
Parameter description
Section: Indicates the road segment of the current point.
Normal Offset: The positive and negative sign indicates whether the pick point is on the left
or right side of the route, and the value indicates the 2D distance between the pick point and
pile-by-pile.
Use Route Parse: After checking this box, piling will be interpolated according to the resolved
route. After deselecting, piling can be added when there is no result of route analysis.
Use Selected Points Height: After checked, the elevation value of interpolation point is
determined by the elevation value of capture point.
Add to Current: After checking, click Export, the result of view piling will be saved in the 3D
pile-by-pile that is currently activated.

3.4.2.4.2. Mile Add

Description
Manually input the mileage value, in the input position, add a pile point.
Steps

 Import route point cloud, use the flat curve function to calculate the route and generate

pile by pile;

 Use the "Prifile Section" function to generate 3D pile by pile (optional);

 Activate the mile add function, enter the mileage adding pile, and click OK;

Notes
Mileage piling must have a calculated route, and the piling results will be directly loaded to
the current pile by pile.

3.4.3. Road Survey

3.4.3.1. Profile Section
Description
Generate profile according to imported point cloud and pile-by-pile, or generate 3D pile-by
-pile.
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Steps

 Import route point cloud and 2D pile-by-pile file;

 Click the road module -> Road Survey -> Profile Section;

 Setting whether the features are simplified, click ProfileSection or RoutePiles.

 RoutePiles means generating 3D pile-by-pile.

As shown in the figure above, purple dots and yellow tracks represent the resulting
longitudinal section on the point cloud.
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Parameter Settings:
Simplified threshold: the feature pile points with the difference between the height before
and after and less than this value will be deleted. This feature must have a calculated route
to use.
Clipping width: the left and right sides of the route participate in the calculation of the
number of point clouds when the longitudinal section is extracted.

3.4.3.2. Profile Editing
Description
Edit the automatically generated profile and support saving the edit results to pile by pile.
Steps

 After the profile is generated, click the Profile Edit function to open the profile view.

 By default, the section between the first two pile points is opened, and the main view

will switch to the corresponding section.

As shown in the above figure, the section view shows the pile number and corresponding
elevation of the two pile points before and after, the section line between the two points and
the vertical grid cable. The grid lines are spaced 1m apart by default. The original pile points
are shown in red, and the new pile points are shown in green.

Skip to the previous section

Skip to the previous section of the current display section.

Skip to the currect section

If multiple profiles are currently loaded, select one of them and click " Skip to the currect
section " to display the selected profile in the profile edit view.

Skip to the next section

Skip to the next section of the current display section.

Add Node

Click "Add Node" or shortcut key A, click on A point on the vector line, and add A node at
that point.
When you enter section editing, the add node function is enabled by default.
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Delete Node

Click "Delete Node" or shortcut key D, click a node on the vector line to delete the selected
node.

Move Node

Click "Move Node" or shortcut key M, click and drag a node on the vector line to change the
position of the node. If you click on the vector line where there are no nodes, a new node
will be added and the move command will be executed.

Undo

Click Undo or shortcut key U to undo the previous edit of the cross section.

Redo

Click Redo or shortcut key R to roll back the previous undo action for cross-sectional editing.

Slice Settings

Change the thickness, length and grid interval of the point cloud in the view.

Jump

Enter the road segment and mileage values to jump the section view to the location of the
target mileage.

Relock

Restore the section view to the preview state when browsing.
You can use this feature to restore the profile view if its rotation lock state is released during
browsing.

Grid

Hide/display the grid line.
3.4.3.3. Cross Section

Description
Generate the cross section and vertical section of the road according to the preview section,
or directly generate the section without preview.
Steps
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 After there is no problem in section preview, click Generate to extract and calculate

section feature points.

Parameter description
Crop Param:
Section Point Clipping Width: The extent of the point cloud that participates in the
construction of the network when generating the section points on the cross-section. If the
setting is too small, there may be location extraction failures; If the setting is too large, the
extraction efficiency will be lower.
Clip width of the middle pile point: If the current pile does not have elevation information,
the point cloud extent participating in the network construction when calculating the
elevation of the middle pile point of the cross-section. If the setting is too small, the
extraction may leak piles; If the setting is too large, the extraction efficiency will be lower.
Generation method:
Overwrite the original section: When you regenerate a cross-section, the original section is
cleared and regenerated.
Generate Modify Pile Section: When you regenerate sections, only the currently new
stations with elevation changes are generated.
Length Limit: the maximum triangulation net side length when constructing TIN.
Clipping Distance: the distance between two adjacent points in the cross section when
extracting feature points.
Section Rotation: the clockwise or anti-clockwise section rotation function requires loading
section data.
Topographic Features: Sample by terrain features, and extract terrain feature points by
considering equal intervals and elevation differences.
Clipping Distance: the length of the left and right sides of the resulting longitudinal section.
Note
The rotate section clockwise or counterclockwise feature requires the section data to be
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loaded.
3.4.3.4. Section Editing

Description
Correct the deviation between the cross section and the point cloud by vector editing in the
cross section view.
Steps

 Click Section Edit to open section view. By default, open the cross section view of the

first pile number.

 The section view of the selected section can be viewed to realize the up-down switching

of the section view and the setting of section parameters.

 As shown in the section view below, the red and yellow vector lines are the current

section lines that can be edited.

 The orange dotted line is the next section line, the blue dotted line is the previous

section line, and the orange and blue dotted lines are not editable.

Skip to the previous section

Skip to the previous section of the current display section.

Skip to the currect section

View the currently selected section.

Skip to the next section
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Skip to the next section of the current display section.

Add Node

Click "Add Node" or shortcut key A, click on A point on the vector line, and add A node at
that point.
When you enter section editing, the add node function is enabled by default.

Delete Node

Click "Delete Node" or shortcut key D, click a node on the vector line to delete the selected
node.

Move Node

Click "Move Node" or shortcut key M, click and drag a node on the vector line to change the
position of the node. If you click on the vector line where there are no nodes, a new node
will be added and the move command will be executed.

Undo

Click Undo or shortcut key U to undo the previous edit of the cross section.

Redo

Click Redo or shortcut key R to roll back the previous undo action for cross-sectional editing.

Slice Settings

Modify the thickness and length of the section in section view.
Step:

 Click the section parameter setting button above the section view to modify the section

thickness or length, and click Apply. Then the section thickness or length in the section

view can be updated and displayed in real time.

 If the function of previewing front and back sections is selected, the track of front and

back sections will be shown in orange and blue in the section view, respectively.
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Show Height

Displays the current elevation at the cross section point.

Show gridlines

Display grid lines in section view.
3.4.3.5. Delete Node

Description
Delete the node of the section on the main view.
Steps

 Generate cross section;

 Click Road Module ->Road Survey ->Delete Node to activate the point deletion function;

 Click the node on the cross section in the main view to delete it.

Notes
At present, the point deletion function can only be used to delete points on the cross section,
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and does not support the deletion of center stake points.
3.4.3.6. Section Display

Steps

 After the cross section is generated, click Hide All to realize the hiding of all sections;

Click Show All to display all hidden sections;

 Select multiple sections and click Show Selected sections to display specific sections.

Click Hide Selected to realize the hidden selected section;

 Click Clear All to clear all section views and section nodes.

3.4.3.7. Section Results
Steps

 Click the road module -> Road Survey -> Section Results -> Export Profile/Cross;

 Set the file name, select the export file format, and click Save;

 Select “Export all sections” or “Export only selected sections”, Export all sections is

selected by default;

 After setting, click Export to save profile/cross section results successfully.
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3.4.3.8. Generate Section View
Description
Generate the DXF format sectional view from the HDM file

Steps

 Click the function of generating sectional view;

 Click Import file and select HDM file;

 Modify the drawing base point and spacing, right click on a section can set its pile

number as the starting pile number or the end pile number;

 Set the output path;
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 Click "Cross section Design Drawing" after setting.

 After drawing, you can find the drawn DXF file in the output path.

3.4.4. Other Tools

3.4.4.1. Manual Extract
Description
Manually draw a line on the point cloud.
Steps

 Click Other Tools - > Manual Extract;

 Click the left key on the point cloud for many times to draw multi-segment lines;

 After drawing, right-click and choose Generate Markline or Interpolation to generate

mark line.
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Generate Markline
Generate lines directly frommanually drawn nodes.
Interpolate to generate markline
Interpolate the result line at 1 meter intervals.

3.4.4.2. Vector Editing
Description
Add, delete, or shift points to manually extracted or imported marks.

3.4.4.2.1. Add Node

Click the road module -> Road Survey -> Other Tools -> Add Node, or use the shortcut key A
in the edit function, move the mouse to the position of adding node, and click the left button
to add a point on the vector line.
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3.4.4.2.2. Delete Node

Click the road module -> Road Survey -> Other Tools -> Delete Node, or use the shortcut key
D in the edit function, move the mouse to the node to be deleted, and click the left button to
delete the point on the vector line.

3.4.4.2.3. Move Node

Click the road module -> Road Survey -> Other Tools -> Move Node, or use the shortcut key
M to drag the mouse from a point to move a point on the vector line.
If you move a point from the original point, a new point is added, and then the new point is
moved.

3.4.4.3. Markline Sample

3.4.4.3.1. Baseline

Description
Reference sampling of a line according to a fixed step size.
Steps

 Select a line under the line node;

 Click the road module -> Other Tools -> Markline Sample -> Baseline;
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 Click Start sampling to generate a line with a fixed sampling interval.

If you want to retain the original midpoint of the line and delete the original line, select the
corresponding option;
It is recommended to select the relatively complete line with more points as the benchmark
sampling line.

3.4.4.3.2. Parallel

Description
The line sampled by datum is used as the reference line for parallel sampling of other routes.
Steps

 Click the road module -> Other Tools -> Markline Sampling -> Parallel;

 Select the newly generated line after datum sampling as the datum line;

 Select the line to be sampled under the line node in the left road project;

 Click "Add from Project" to load the sampling line directory and click Sampling.

Sampling distance threshold：

There is a reference line and a sampling line. The reference line has a point on it that is
perpendicular to the sampling line.To determine if the reference point will be sampled, we
need to calculate the sum of the distance between the vertical and the left and right points
on the sampling line. If this sum is greater than the set value, then the reference point will
not be sampled.
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3.4.4.4. Data Cropping
Description
According to the imported pile-by-pile file, the point cloud is cut along the left, right, up and
down sides of the pile line.
Steps

 Right-click on one of the pile-by-pile nodes and select "Set Current";

 Select a point cloud under the point cloud node and click the Roads module -> Other

Tools -> Data Cropping;

 Set the cutting type and the left and right distance from the pile line, and click OK.
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3.4.4.5. 3D-interpolation
Description
The 2D vector lines are converted into three-dimensional vector lines by 3D -interpolation
and attached to the point cloud.
Steps

 Import 2D DAT or DXF vector line;

 Click the road module -> Others -> 3D-Interpolation;

 Select the point cloud filtering in the interpolation process;

 Click OK to view the 3d interpolation effect as shown in the figure below after the

progress processing is completed.
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3.5. Volume

3.5.1. Project Manager

3.5.1.1. New Project
Description
Create a new Volume project.
Steps

 Click Volume -> Project Manager -> New Project, select the project path, enter the

project name, and click OK to create the project;

 Project directory generates Cvp project file, PointCloud, TIN, Vector and Result folders.

3.5.1.2. Open Project
Description
Open an Volume project.
Steps

 Click Volume -> Project Manager -> Open Project;

 Select the project path, Select CRS project file and click Open to load intelligent

Extraction project.

3.5.1.3. Save Project
Description
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After creating or opening a project, click Save Project to save the existing operations.

3.5.2. Point Cloud Processing

3.5.2.1. Filtering
Description
The filtering function can quickly separate the ground points from the input point cloud,
which is convenient for the subsequent TIN construction and volume calculation.
Steps

 Add Las point cloud to be filtered in the project;

 Click Volume ->Point Cloud Processing ->Filtering, open the filter dialog box;

 Select the filtering point cloud in the point cloud list;

 Select the filtering to be performed and set the filtering parameters.

 Click Start to automatically classify the added point cloud.

Filtering method Description
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Isolate Point Filter:
The points in the point cloud data whose number of points in a certain neighborhood is less
than the specified value are identified as outliers. This function is mainly used to remove
outliers in the air or below the ground. The outliers are far away from the main point cloud
and have the characteristics of few points and discrete distribution.
Ground point Filter:
It is used to classify ground points and non-ground points, supporting different terrain such
as flat terrain, hill terrain and mountainous terrain.
Key Point Filter:
According to the set percentage of feature points, some special points are extracted from the
ground points.
Parameter Settings:
Maxi building size: This parameter controls the size of the progressive window of the
morphological filtering algorithm and the number of iterations. Generally refers to the length
of the diagonal, that is, the longest distance of the hypotenuse of the building.
Maxi Terrain Angle: the section with the steepest slope is selected as the max terrain Angle.
Iteration Angle: Three vertices from a point to a triangulation constitute the maximum Angle.
The larger the iteration Angle is, the farther the points are from the triangulation network. In
the process of iteration, the points that are far away and meet the iteration Angle will be
added to the ground points, which should not be set too large.
Iteration Distance: vertical distance from a point to the plane of the triangulation network.
Point density: the degree of dilution of the filtering result. General operations do not require
very dense ground points.
Percentage of feature points: Howmany of the ground points are classified as key Points.

3.5.2.2. Flatten
Description
According to the selected vector line, the point cloud within the range is fitted and flattened
according to the boundary of the vector line. It can be used to clear ground equipment and
repair missed test areas.
Steps

 Load the point cloud to be flattened;
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 Use vector line drawing or import function to obtain the boundary vector line of the

flattened area;

 Click Volume -> Point Cloud Processing -> Flatten, open the flatten dialog box;

 4. Select the processing range vector line and processing point cloud;

 5. Click OK. After the progress bar is executed, a point cloud with the suffix "_Flatten"

will be generated under the point cloud node of the square project.

3.5.2.3. Export Ground Points
Description
Export the ground points in the selected point cloud to the project results folder.
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Steps

 Load the point cloud to generate triangulation network in the project;

 Use the filtering function to filter the point cloud.

 Click Volume module -> Point Cloud Processing -> Export Ground Points;

 Select the appropriate point cloud and click Start.

 After the export is complete, the software outputs the points and paths of the ground

points

3.5.3. Triangulation

3.5.3.1. Build TIN

3.5.3.1.1. Direct

Description
According to the point cloud information, the triangulation network of a specific category of
points is constructed.
Steps

 Load the point cloud to generate triangulation network in the project;

 Click Volume module-> Triangulation -> TIN;

 Select the point cloud to generate triangulation network;

 Select the type of point;

 Click OK.

Parameter Settings:
Points Type: Controls the type of points that participate in network construction. You can
select all points, or filtered ground points and other types of points.
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3.5.3.2. Boundary Constrain
Description
According to the point cloud information, the triangulation network of a specific category of
points is constructed.
Steps

 Load the point cloud to generate triangulation network in the project;

 Click Volume module-> Triangulation -> TIN;

 Select the point cloud you want to participate in generating.

 Select Add DXF in Parameter Settings;

 Adjust the mesh type and boundary smoothing method and check the vector lines

involved in the mesh construction;

 Click OK to generate the result of boundary constraint network.
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Parameter Settings:
TIN Type: When selecting the constraint network, the selected vector line will constrain the
range of triangulation network generation; When selecting to participate in network
construction, the selected vector lines will participate in the generation of triangulation
network.
Point Type: Controls the type of points that participate in network construction. You can
select all points, or filtered ground points and other types of points.
Boundary smoothing: When selecting boundary constraints to construct the network, the
smoothing method of the generated triangulated network boundary area can be adjusted,
including low smoothing, moderate smoothing, high smoothing and direct use of the original
position (no smoothing).
Among them, after the boundary smoothing function is enabled, the constraint line will be
sampled first when constructing the net, and the sampling points and the points within the
constraint range will be constructed together. The higher the smoothness, the more
sampling points participate in network construction. The effect of boundary smoothing is
shown in the figure below:
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3.5.4. Single Volume Calculation

3.5.4.1. Projected Volume
Description
Calculates the projected volume of the triangulation network against the current reference
surface.
It can get the maximum and minimum elevation, starting elevation, projection volume,
excavation/filling volume, occupied area and other results, and also support one-key output
volume report.
Steps

 Create a TIN using the TIN function;

 Define a reference surface using the reference surface Settings function;

 Click Volume -> Single volume Calculation -> Projected Volume;

 Select the calculation triangulation network in the pop-up dialog box;

 Click OK to set the heap density and report title in the second page.

 Click Export to obtain the projection volume report results.
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3.5.4.2. Grid Volume
Description
The point cloud within the range of vector line is divided into several grid grids according to
the set grid edge length, and then the fill volume in each grid is calculated.
All figures in this section are in meters, square meters, or cubic meters.
Steps

 Load the point cloud and constraint vector to be compared and analyzed, where the

vector can be drawn by itself or imported from the outside;

 Click Volume -> Single Volume Calculation -> Grid Volume;

 Select point cloud and constraint vector line data in the calculation area in the selection

box;

 Adjust the calculation parameters, select the calculation method and projection

reference surface;
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 Adjust the grid length;

 Click OK to complete the calculation.

After the calculation is completed, the calculation result of a single phase grid will appear
under the "calculation result" node in volume project. As shown in the picture below:

In the figure, T represents the amount of filling and W represents the amount of digging. The
yellow number near each grid node represents the elevation of the corresponding point
cloud of the grid dot, the blue number represents the elevation of the reference surface, and
the pink number represents the difference between the two.
Parameter Settings:
Traditional Square Grid method: When selecting the traditional grid method, the software
will calculate the column volume in each square.
Triangulation method: When choosing triangulation network method, the software will
calculate the volume of triangulation network projected to the reference surface in each grid,
and the calculation result is more accurate.
Reference plane Settings:
Model Lowest Point: When this item is selected, the elevation value of the calculated
reference surface will be set to the elevation of the lowest point in the point cloud model.
Target Elevation: When selected, the elevation of the calculated reference surface is set by
the user.
Reference plane: If this item is selected, the current reference plane will be used for
calculation. If there is no reference plane, the lowest point of the model will be used by
default.

3.5.4.3. Closed Volume
Description
Calculate the volume of the closed triangulation generated by the projection of the
triangulation onto the reference surface.
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Steps

 Create a projection triangulation using the projection to reference surface function.

 The hole filling function is used to repair the hole of the projection triangulation

network.

 Click Volume -> Single Volume Calculation -> Closed Volume;

 Select the projection triangulation you want to calculate and click OK.

The calculated closed volume is shown in the third column of the table corresponding to the
triangulation.

3.5.5. Multi Volume Calculation

3.5.5.1. Volume Comparison
Description
The triangulation data and constraint vector lines of the two-phase project are used to
calculate the amount of excavation square and the elevation before and after excavation.
Steps

 Use the network function to generate triangulation network of two phases in the

engineering area;
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 Click Volume->Multi Volume Calculation -> Volume comparison ;

 In the selection box, select the triangulation data of the two-phase project and the

constraint vector line data of the contrast area;

 Click calculation to generate the volume comparison results of the two phases;

 On the second page, set the report title and test area properties, and click Calculation.

 Click Generate report to complete the comparison work and output the two-phase

volume comparison report.

Notes
must import constraint range vector lines.

3.5.5.2. Grid Comparison
Description
The square grid calculation method is used to compare the filling and digging amount of
point clouds in two stages.
Steps
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 Load the point cloud and constraint vector to be compared and analyzed, where the

vector can be drawn by itself or imported from the outside;

 Click Volume->Multi Volume Calculation -> Grid comparison ;

 The point cloud data of the first phase and the second phase were selected respectively,

and the constraint region vector range line was selected.

 Set the edge length of the grid and click Calculate.

Similar to the function of grid volume, the calculation results are saved under the
"Calculation Results" node of the project. The amount of filling and digging in each square is
represented by T and W.
In the above picture, “T” represents the filling amount and “W” represents the digging
amount; The yellow number near each grid node represents the elevation of the former
phase point cloud, the blue number represents the elevation of the later phase point cloud,
and the pink number represents the difference between the two phases.

3.5.5.3. Change Analysis
Description
By comparing the point cloud data of the two periods, the change of earthwork in the
construction area is monitored and the bulk volume of the reactor is roughly calculated.
Steps

 Load the point cloud and constraint vector to be compared and analyzed, where the

vector can be drawn by itself or imported from the outside;

 Click Volume->Multi Volume Calculation ->Change Analysis ;
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 Select the point cloud data of the first phase and the second phase respectively and

load them into the dialog box.

 If boundary constraints are required, check the "Add constrained region" option and

select the corresponding vector in the list.

 Click OK to automatically calculate the difference between the point cloud data of the

two periods and generate a diff map.

 Click the "change area detection" button to extract the change track line of the change

area;

 Click the "Report Export" button to generate a change analysis report with one click.

The diff map generated by the software is shown in the figure above. The blue vector line is
the fill line and the pink is the cut line.
Parameter setting:
Original Method: When selecting this method, compare the point cloud directly. The change
value is obtained by subtracting the elevation value of the first phase point cloud from the
elevation value of the second phase point cloud data. big
Use this method for some scenarios.
Delete Missing Areas: When selecting this method, compare the point cloud directly.
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Similarly, the elevation value of point cloud data in the second phase is subtracted from the
elevation of point cloud in the first phase, but the point cloud region that does not repeat
will not participate in the calculation of heat map.
This method is suitable for little change, or part of the area missed scanning, using the first
method results are not good.
Complete Missing Areas: When selecting this method, the software will first build a
triangulation network against the point cloud, and then compare the triangulation network.
In this way, we can use the method of network to complete part of the missing sweep area.
This method is suitable for computing scenarios where partial missing regions need to be
fitted.

3.5.5.4. Diff Colorzation
Description
Adjust the rendering mode of the thermal map generated by the change analysis for easy
browsing.
Steps

 After generating a thermal map using the change analysis function, click on the Volume

->Multi Volume Calculation ->Change Analysis;

 Set the ribbon and range in the Settings dialog box, the rendering mode of the thermal

map point cloud in the view will be changed, and the points that are not in the range

will be rendered white.

The range of variation is in meters.

3.5.6. Vector Achievements

3.5.6.1. Bench Lines
Description
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Can quickly extract the bench crest and bench toe, and vector display.
Steps

 The triangulation network of the engineering area is generated using the functions of

network construction and clipping.

 Click Volume ->Vector Achievements-> Bench Lines;

 Select the corresponding triangulation network in the triangulation network list;

 Set the slope Angle threshold and smoothness threshold;

 Click Execute to extract the slope top and bottom line, and give the quantity statistics of

the two lines.

Parameter Settings:
Slope Angle threshold: controls the slope extraction, and places where the relief Angle is
greater than this value will be considered as profiles. The default 15 °.
Smoothness threshold: controls the extraction of the vector line. If the Angle between two
segments of the vector line is greater than the set value, the vector line will not be extracted.

3.5.7. Vector Line Processing

3.5.7.1. Draw
Description
Draw DXF vector lines by clicking several points on the point cloud or triangulation.
Steps

 Import the point cloud of the project area;
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 Click Volume-> Vector Line Processing -> Draw, activate the draw function;

 Click a few points on the point cloud to draw a vector line;

 After the drawing is finished, right-click and choose "Closed" or "Finish" to complete the

drawing of vector line.

Notes
If you want to get a closed vector line, select "Closed", otherwise select "Finish".

3.5.7.2. Import
Description
Import a DXF vector line in the specified path into the project.
Steps

 Click Volume-> Vector Line Processing -> Import;

 In the dialog box that pops up, select the DXF file you want to import and click OK.

 If the DXF file is correctly formatted, it will be imported into the project and displayed in

the view.

3.5.7.3. Export

3.5.7.3.1. Export Vector Line

Description
Export the vector line under the node to local.
Steps

 Select the vector you want to export,

 Click Volume-> Vector Line Processing -> Export Vector Line;

 Select a save path, Click Save to write the DXF vector line to the local.

3.5.7.3.2. Export Elevation Points

Description
Only nodes in vector lines are exported.
Steps
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 Select the vector you want to export,

 Click Volume-> Vector Line Processing -> Export Vector Line;

 Select a save path, Click Save to write the DAT points to the local.

3.5.7.4. Vector Editing
Description
Implement node selection, delete, add, move, undo and redo.

3.5.7.4.1. Select Line

Click Volume -> Vector Line Processing -> Vector Editing -> Select Line to begin selection.
Support click, rectangular box selection.
Click
Click a vector line to select; Hold down the Ctrl key and click multiple vector lines in turn to
select multiple vector lines. The selected vector lines are shown in green.
Rectangular box selection
Hold down Ctrl and drag the left mouse button to drag a rectangular area.
If selected from the upper left corner to the lower right corner, the vector lines that are fully
contained in the region are selected, otherwise the vector lines that intersect the rectangular
box are selected.
Notes
When vector lines are selected, the vector lines that have already been selected are
deselected by selecting the vector lines again via the rectangular box selection.

3.5.7.4.2. Add Node

Click Volume -> Vector Line Processing -> Vector Editing ->Add Node, move the mouse
pointer to the position where the node needs to be added, and click the left button when
the "x" shaped symbol appears.

3.5.7.4.3. Delete Node

Click Volume -> Vector Line Processing -> Vector Editing ->Delete Node, move the mouse
pointer to the node and click the left button to delete it.

3.5.7.4.4. Move Node

Click Volume -> Vector Line Processing -> Vector Editing -> Move Node, select the point to
move with the left key and drag the mouse to move the selected point to the specified
position.
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3.5.7.4.5. Break

Click Volume -> Vector Line Processing -> Vector Editing -> Break, Click on a vector line in the
view to break it into two.

3.5.7.4.6. Merge

Click Volume -> Vector Line Processing -> Vector Editing -> Merge, Click one vector line in the
view, and then the other to merge the two vector lines into one.

3.5.7.4.7. Undo

After the edit point, click Undo to undo the last operation.

3.5.7.4.8. Redo

After undoing the last edit, click Redo to restore the state before undoing.

3.5.7.4.9. Change Vector Attributes

Description
Right-click the vector line node to modify the properties of the vector line. Support manual
modification of line name, layer information (bench crest, bench toe), and other
personalized information, and support with the project.
Steps

 Draw or import vector lines;

 Right-click the vector line node and click the Change Properties function

 Modify the information in the dialog box that is displayed

 Click Apply to save the modified property information.
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3.5.7.5. Dot Symbol
Description
Change the display size of the vertices in the vector line for easy browsing.
Steps

 Draw or import vector line objects;

 The dot symbol button is activated by default, and the vertices on the vector lines

appear as distinct gray squares.

 Click Volume-> Vector Line Processing->Dot symbol;

 The vertex display becomes smaller.

3.5.7.6. Sampling
Description
The selected vector line is sampled at the set sampling interval and fitted to the point cloud
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model.
Steps

 Import the point cloud and sampling line in the working area;

 Click Volume-> Vector Line Processing -> Sampling;

 Set sampling interval;

 Click OK to generate the sampling vector.

Parameter Settings:
Sampling interval: Refers to the sampling interval and the distance between sampling points.

3.5.8. Reference Plane

3.5.8.1. Project to Reference Plane
Description
According to the currently set reference surface, the closed triangulation region is obtained
by projecting the triangulation network onto the reference surface to facilitate the
calculation of the closed volume.
Steps

 Define a reference surface using the reference surface Settings function;

 Click Volume -> Reference Plane -> Project to Reference Plane;

 Select the triangulation you want to project and click OK.

 After the calculation, the parts of the triangulation network above the reference surface
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are projected onto the reference surface, and the parts below the reference surface are

not processed.

3.5.8.2. Reference Plane Settings

3.5.8.2.1. Single Point

Click a point on the point cloud to create a reference surface with the same elevation as the
point.

3.5.8.2.2. Three Points

Click three points on the point cloud to fit a plane and use the plane as the reference plane.

3.5.8.2.3. Reset

Clears all reference planes currently set.

3.5.8.2.4. Set elevation

Create a reference surface with a fixed elevation by setting the elevation value.

3.5.9. TIN Editing

3.5.9.1. Filtering
Description
The surface whose edge length exceeds the set threshold is filtered out, and the surface
whose boundary area is too large can be effectively filtered out.
Steps
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 The triangulation network of the engineering area is generated using the functions of

network construction and clipping.

 Click Volume module -> Triangulation Editing -> Filtering;

 In the dialog box, select the triangulation network to be filtered, and set the edge

length threshold of triangulation network;

 Click the Detection, the surface boundary of the triangulated network beyond the

threshold will be extracted;

 Click OK, the surface exceeding the threshold in the original triangulation network will

be deleted, and the filtering result triangulation network will be generated.

3.5.9.2. Hole Filling
Description
Fill the holes in the triangulation network, form a closed TIN, easy to calculate the closed
volume.
Steps

 Create a projection point cloud using the projection to reference surface function.

 Click Volume module -> Triangulation Editing -> Hole Filling;

 Select the triangulation network to be filled in the triangulation network list;

 Click OK to create a hole-filling triangulation.

 Select the filled border in the second dialog box that pops up;
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 Click Fill to obtain the filling result of holes.

3.5.9.3. Smooth
Description
The overall triangulation network is smoothed according to the set parameters to increase
the number of facets of the triangulation network and effectively reduce the sharpness of
the triangulation network.
Steps

 The triangulation network of the engineering area is generated using the functions of

network construction and clipping.

 Click Volume module -> Triangulation Editing -> Smooth;

 In the dialog box, select the triangulation network to be smoothed, and set the

smoothness;

 Click OK to generate the smoothed triangulation network.

3.5.9.4. Simlify
Description
The more complex triangulation network is simplified. After the simplification is completed,
the output window will prompt the number of simplified slices.
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Steps

 The triangulation network of the engineering area is generated using the functions of

network construction and clipping.

 Click Volume -> Triangulation Editor -> Simplify;

 In the dialog box to check the simplified triangulation;

 Set the slice retention ratio;

 Click OK to generate the simplified triangulation network.

Patch Retention Scale: Controls how many facets of the original triangulated network will be
retained by the simplified triangulated network.

3.5.10.Crop

Description
Use constraint vector to trim the point cloud model or triangulation network model to
generate a new model.
Point Cloud

 Import the point cloud in the area;

 Use the vector line processing function to draw the boundary of the area of interest, or

import the boundary from the outside;

 Click Volume ->Crop ->Point Cloud;

 Check the clipping boundary constraint line and point cloud to be clipped;

 Click Execute to generate clipping result point cloud.
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3.5.10.1.Traingulation

 Use the net function to obtain triangulation network;

 Use the vector line processing function to draw the boundary of the area of interest, or

import the boundary from the outside;

 Click Volume ->Crop -> Triangulation;

 Check the clipping boundary constraint line and the triangulation network to be

clipped;

 Click Execute to generate clipping result triangulation.



CHCNAV COPROCESS2.6 USER MANUAL P a g e | 290

3.5.10.2.Base map update

3.5.10.2.1.Point cloud update

Description
The point cloud update function can merge part of a point cloud set to another point cloud
set to realize the partial update of the point cloud.
Steps

 Import two point cloud sets with overlapping areas, import or draw the range line of

the update area.

 Click on the point cloud update function and select the base map in the first box, the

point cloud to be updated in the second box, and the range line in the third box.

 Click Update to generate an updated point cloud set.

Point Cloud 1

Point Cloud 2
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Update

3.6.Help
User can check more information about software on “Help”.

3.6.1. Help

User can find latest software user manual under this option.

3.6.2. Version

User can check current software version and detect latest version to update.

3.6.3. Update

User can check release note about new features and solved bugs.

3.6.4. Language

User can switch software language here: Chinese and English .



CHCNAV COPROCESS2.6 USER MANUAL P a g e | 292

CHC Navigation
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577 Songying Road, 201703, Shanghai, China
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Email: sales@chcnav.com | support@chcnav.com
Skype: chc_support
Website: www.chcnav.com
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